Closed Bug 1632259 Opened 4 months ago Closed 3 months ago

Refactor WebRender configuration logic in gfxPlatform to be testable

Categories

(Core :: Graphics, task, P2)

task

Tracking

()

RESOLVED FIXED
mozilla77
Tracking Status
firefox77 --- fixed

People

(Reporter: aosmond, Assigned: aosmond)

References

Details

Attachments

(1 file)

No description provided.

We have encountered issues when rolling out WebRender because the
configuration logic is quite complicated. It would serve us well to have
it in a form that we can easily test. This patch does said refactor, as
well as adds an initial set of tests.

Is this ready to land?

Flags: needinfo?(aosmond)
Pushed by aosmond@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7ba7a04cfa43
Refactor WebRender configuration logic in gfxPlatform to be testable. r=jrmuizel
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla77
Regressions: 1635069
Regressions: 1638413
Flags: needinfo?(aosmond)
You need to log in before you can comment on or make changes to this bug.