If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

tabbing behavior in forms

RESOLVED DUPLICATE of bug 28583

Status

()

Core
Layout: Form Controls
--
enhancement
RESOLVED DUPLICATE of bug 28583
15 years ago
15 years ago

People

(Reporter: Phil Barton, Assigned: rods (gone))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b) Gecko/20020721
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b) Gecko/20020721

pressing the tab key to navigate through forms is somewhat innefficient. 
tabbing to a text box should result in the text being hilighted, not just focussing.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



Expected Results:  
using the tab key to navigate through forms should allow the user to quickly and
efficiently enter/edit data.  tabbing from one text box to another should result
in the text in the box being hilighted (for easy deletion/editting).  while the
text is highlighted, pressing the left arrow should result in the cursor moving
to the front of the value, pressing the right arrow should result in the cursor
moving to the end of the value.  the tabbing innefficiency results in mozilla
being kind of a bear for users who eBay or routinely enter data through
web-based interfaces.
interesting idea
Assignee: Matti → rods
Component: Browser-General → HTML Form Controls
QA Contact: asa → tpreston

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 28583 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.