Closed Bug 1632539 Opened 10 months ago Closed 10 months ago

Edit bookmark panel color changed in dark theme

Categories

(Firefox :: Theme, defect, P3)

77 Branch
All
macOS
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox-esr68 --- unaffected
firefox75 --- unaffected
firefox76 --- unaffected
firefox77 --- wontfix

People

(Reporter: bogdan_maris, Unassigned)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Affected versions

  • Firefox Nightly (2020-04-23)

Affected platforms

  • MacOS 10.15.5

Unaffected platforms

  • Windows 10 64bit
  • Ubuntu 18.04 64bit

Steps to reproduce

  1. Start Firefox
  2. Make sure to have the Dark theme enabled
  3. Visit any website
  4. Bookmark the page by clicking the star icon
  5. Click Show all the bookmark folders
  6. Hover + New Folder button

Expected result

  • Hovering + New Folder button has the same color as the panel

Actual result

  • Hovering + New Folder button has a different color as the panel

Regression range

Additional notes

  • Not sure if this change was intended or not, it looks kind of wrong to me. Andrew can you share your opinion here?
  • The panel from the left is the one that I consider bad (Latest Nightly).
Flags: needinfo?(aosmond)
Has Regression Range: --- → yes
Has STR: --- → yes

The change is likely intended from the graphics perspective (barring some bug in the profile handling). We did not color manage CSS colors before, so the way they would show up on different monitors was completely different. Now it should be fairly consistent. I'm not sure what front end expected in this case however.

Flags: needinfo?(aosmond) → needinfo?(dao+bmo)
Priority: -- → P3

The button hover background matched the panel background only approximately, and only by accident, I think. This change seems fine.

Status: NEW → RESOLVED
Closed: 10 months ago
Component: Graphics: Layers → Theme
Flags: needinfo?(dao+bmo)
OS: All → macOS
Product: Core → Firefox
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.