Closed Bug 1633639 Opened 3 months ago Closed 3 months ago

[rustc 1.43] error: unused doc comment

Categories

(WebExtensions :: Storage, defect)

defect

Tracking

(firefox75 unaffected, firefox76 unaffected, firefox77 fixed)

RESOLVED FIXED
mozilla77
Tracking Status
firefox75 --- unaffected
firefox76 --- unaffected
firefox77 --- fixed

People

(Reporter: glandium, Assigned: glandium)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

[task 2020-04-28T02:04:55.122Z] 02:04:55     INFO -  error: unused doc comment
[task 2020-04-28T02:04:55.122Z] 02:04:55     INFO -    --> toolkit/components/extensions/storage/webext_storage_bridge/src/area.rs:81:5
[task 2020-04-28T02:04:55.123Z] 02:04:55     INFO -     |
[task 2020-04-28T02:04:55.123Z] 02:04:55     INFO -  81 |     /// Sets up the storage area.
[task 2020-04-28T02:04:55.123Z] 02:04:55     INFO -     |     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ rustdoc does not generate documentation for macros
[task 2020-04-28T02:04:55.124Z] 02:04:55     INFO -     |
[task 2020-04-28T02:04:55.124Z] 02:04:55     INFO -     = note: `-D unused-doc-comments` implied by `-D warnings`
[task 2020-04-28T02:04:55.124Z] 02:04:55     INFO -     = help: to document an item produced by a macro, the macro must produce the documentation as part of its expansion
[task 2020-04-28T02:04:55.125Z] 02:04:55     INFO -  error: unused doc comment
[task 2020-04-28T02:04:55.125Z] 02:04:55     INFO -     --> toolkit/components/extensions/storage/webext_storage_bridge/src/area.rs:113:5
[task 2020-04-28T02:04:55.125Z] 02:04:55     INFO -      |
[task 2020-04-28T02:04:55.125Z] 02:04:55     INFO -  113 |     /// Sets one or more key-value pairs.
[task 2020-04-28T02:04:55.126Z] 02:04:55     INFO -      |     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ rustdoc does not generate documentation for macros
[task 2020-04-28T02:04:55.126Z] 02:04:55     INFO -      |
[task 2020-04-28T02:04:55.126Z] 02:04:55     INFO -      = help: to document an item produced by a macro, the macro must produce the documentation as part of its expansion
[task 2020-04-28T02:04:55.126Z] 02:04:55     INFO -  error: unused doc comment
[task 2020-04-28T02:04:55.127Z] 02:04:55     INFO -     --> toolkit/components/extensions/storage/webext_storage_bridge/src/area.rs:132:5
[task 2020-04-28T02:04:55.127Z] 02:04:55     INFO -      |
[task 2020-04-28T02:04:55.127Z] 02:04:55     INFO -  132 |     /// Gets values for one or more keys.
[task 2020-04-28T02:04:55.127Z] 02:04:55     INFO -      |     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ rustdoc does not generate documentation for macros
[task 2020-04-28T02:04:55.128Z] 02:04:55     INFO -      |
[task 2020-04-28T02:04:55.128Z] 02:04:55     INFO -      = help: to document an item produced by a macro, the macro must produce the documentation as part of its expansion
[task 2020-04-28T02:04:55.128Z] 02:04:55     INFO -  error: unused doc comment
[task 2020-04-28T02:04:55.128Z] 02:04:55     INFO -     --> toolkit/components/extensions/storage/webext_storage_bridge/src/area.rs:150:5
[task 2020-04-28T02:04:55.129Z] 02:04:55     INFO -      |
[task 2020-04-28T02:04:55.129Z] 02:04:55     INFO -  150 |     /// Removes one or more keys and their values.
[task 2020-04-28T02:04:55.129Z] 02:04:55     INFO -      |     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ rustdoc does not generate documentation for macros
[task 2020-04-28T02:04:55.129Z] 02:04:55     INFO -      |
[task 2020-04-28T02:04:55.129Z] 02:04:55     INFO -      = help: to document an item produced by a macro, the macro must produce the documentation as part of its expansion
[task 2020-04-28T02:04:55.130Z] 02:04:55     INFO -  error: unused doc comment
[task 2020-04-28T02:04:55.130Z] 02:04:55     INFO -     --> toolkit/components/extensions/storage/webext_storage_bridge/src/area.rs:168:5
[task 2020-04-28T02:04:55.130Z] 02:04:55     INFO -      |
[task 2020-04-28T02:04:55.130Z] 02:04:55     INFO -  168 |     /// Removes all keys and values.
[task 2020-04-28T02:04:55.130Z] 02:04:55     INFO -      |     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ rustdoc does not generate documentation for macros
[task 2020-04-28T02:04:55.131Z] 02:04:55     INFO -      |
[task 2020-04-28T02:04:55.131Z] 02:04:55     INFO -      = help: to document an item produced by a macro, the macro must produce the documentation as part of its expansion
[task 2020-04-28T02:04:55.131Z] 02:04:55     INFO -  error: unused doc comment
[task 2020-04-28T02:04:55.131Z] 02:04:55     INFO -     --> toolkit/components/extensions/storage/webext_storage_bridge/src/area.rs:179:5
[task 2020-04-28T02:04:55.131Z] 02:04:55     INFO -      |
[task 2020-04-28T02:04:55.132Z] 02:04:55     INFO -  179 |     /// Tears down the storage area, closing the backing database connection.
[task 2020-04-28T02:04:55.132Z] 02:04:55     INFO -      |     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ rustdoc does not generate documentation for macros
[task 2020-04-28T02:04:55.132Z] 02:04:55     INFO -      |
[task 2020-04-28T02:04:55.132Z] 02:04:55     INFO -      = help: to document an item produced by a macro, the macro must produce the documentation as part of its expansion
[task 2020-04-28T02:04:55.132Z] 02:04:55     INFO -  error: aborting due to 6 previous errors
[task 2020-04-28T02:04:55.133Z] 02:04:55     INFO -  error: could not compile `webext_storage_bridge`.
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/c54fde7ed158
Fix new warnings about unused doc comments with rustc 1.43. r=lina
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla77

Set release status flags based on info from the regressing bug 1626506

You need to log in before you can comment on or make changes to this bug.