Closed Bug 1633782 Opened 3 months ago Closed 3 months ago

Perma cram(try) No build detected, test metadata may be incomplete.

Categories

(Firefox Build System :: Task Configuration, defect)

defect

Tracking

(firefox-esr68 unaffected, firefox75 unaffected, firefox76 unaffected, firefox77 fixed)

RESOLVED FIXED
mozilla77
Tracking Status
firefox-esr68 --- unaffected
firefox75 --- unaffected
firefox76 --- unaffected
firefox77 --- fixed

People

(Reporter: aiakab, Assigned: egao)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=299730632&repo=mozilla-central&lineNumber=121

[task 2020-04-28T04:48:03.099Z] $ ./mach try syntax $testargs --preset bar
[task 2020-04-28T04:48:03.099Z] + Creating config file /builds/worker/checkouts/gecko/obj-x86_64-pc-linux-gnu/_tests/web-platform/wptrunner.local.ini
[task 2020-04-28T04:48:03.099Z] + Using config path /builds/worker/checkouts/gecko/obj-x86_64-pc-linux-gnu/_tests/web-platform/wptrunner.local.ini
[task 2020-04-28T04:48:03.099Z] + https://hg.mozilla.org/mozilla-central/json-pushes?changeset=84d37ea90966593e29dfc330720713a7913a2c21&version=2&tipsonly=1
[task 2020-04-28T04:48:03.100Z] + https://firefox-ci-tc.services.mozilla.com/api/index/v1/task/gecko.v2.mozilla-central.revision.cdd14a1df784642f8741b0f76041e92ba99ec9df.source.manifest-upload
[task 2020-04-28T04:48:03.100Z] + Downloading manifest from https://firefox-ci-tc.services.mozilla.com/api/index/v1/task/gecko.v2.mozilla-central.revision.cdd14a1df784642f8741b0f76041e92ba99ec9df.source.manifest-upload/artifacts/public/manifests.tar.gz
[task 2020-04-28T04:48:03.100Z] + https://firefox-ci-tc.services.mozilla.com/api/index/v1/task/gecko.v2.mozilla-central.revision.cdd14a1df784642f8741b0f76041e92ba99ec9df.source.manifest-upload/artifacts/public/manifests.tar.gz
[task 2020-04-28T04:48:03.100Z] + Unpacking meta/MANIFEST.json to /builds/worker/checkouts/gecko/obj-x86_64-pc-linux-gnu/_tests/web-platform/meta/MANIFEST.json
[task 2020-04-28T04:48:03.100Z] + Unpacking mozilla/meta/MANIFEST.json to /builds/worker/checkouts/gecko/obj-x86_64-pc-linux-gnu/_tests/web-platform/mozilla/meta/MANIFEST.json
[task 2020-04-28T04:48:03.101Z] Commit message:
[task 2020-04-28T04:48:03.101Z] try: -b do -p win32 -u none -t all --tag bar
[task 2020-04-28T04:48:03.101Z]
[task 2020-04-28T04:48:03.101Z] Pushed via mach try syntax
[task 2020-04-28T04:48:03.101Z]
[task 2020-04-28T04:48:03.102Z] $ ./mach try $testargs --preset bar
[task 2020-04-28T04:48:03.102Z] + Creating config file /builds/worker/checkouts/gecko/obj-x86_64-pc-linux-gnu/_tests/web-platform/wptrunner.local.ini
[task 2020-04-28T04:48:03.102Z] + Using config path /builds/worker/checkouts/gecko/obj-x86_64-pc-linux-gnu/_tests/web-platform/wptrunner.local.ini
[task 2020-04-28T04:48:03.102Z] + https://hg.mozilla.org/mozilla-central/json-pushes?changeset=84d37ea90966593e29dfc330720713a7913a2c21&version=2&tipsonly=1
[task 2020-04-28T04:48:03.102Z] + https://firefox-ci-tc.services.mozilla.com/api/index/v1/task/gecko.v2.mozilla-central.revision.cdd14a1df784642f8741b0f76041e92ba99ec9df.source.manifest-upload
[task 2020-04-28T04:48:03.103Z] + Downloading manifest from https://firefox-ci-tc.services.mozilla.com/api/index/v1/task/gecko.v2.mozilla-central.revision.cdd14a1df784642f8741b0f76041e92ba99ec9df.source.manifest-upload/artifacts/public/manifests.tar.gz
[task 2020-04-28T04:48:03.103Z] + https://firefox-ci-tc.services.mozilla.com/api/index/v1/task/gecko.v2.mozilla-central.revision.cdd14a1df784642f8741b0f76041e92ba99ec9df.source.manifest-upload/artifacts/public/manifests.tar.gz
[task 2020-04-28T04:48:03.103Z] + Unpacking meta/MANIFEST.json to /builds/worker/checkouts/gecko/obj-x86_64-pc-linux-gnu/_tests/web-platform/meta/MANIFEST.json
[task 2020-04-28T04:48:03.103Z] + Unpacking mozilla/meta/MANIFEST.json to /builds/worker/checkouts/gecko/obj-x86_64-pc-linux-gnu/_tests/web-platform/mozilla/meta/MANIFEST.json
[task 2020-04-28T04:48:03.103Z] Commit message:
[task 2020-04-28T04:48:03.104Z] try: -b do -p win32 -u none -t all --tag bar
[task 2020-04-28T04:48:03.104Z]
[task 2020-04-28T04:48:03.104Z]
[task 2020-04-28T04:48:03.104Z] # Ran 5 tests, 0 skipped, 1 failed.
[task 2020-04-28T04:48:03.211Z] Test configuration changed. Regenerating backend.
[task 2020-04-28T04:48:03.211Z] No build detected, test metadata may be incomplete.
[taskcluster 2020-04-28 04:48:03.569Z] === Task Finished ===
[taskcluster 2020-04-28 04:48:03.569Z] Unsuccessful task run with exit code: 1 completed in 132.593 seconds

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: General → Task Configuration
Flags: needinfo?(egao)
Keywords: regression
Regressed by: 1608837
Summary: No build detected, test metadata may be incomplete. → Perma cram(try) No build detected, test metadata may be incomplete.

:aryx - what is this cram(try) task? The changes that I landed in Bug 1608837 isn't turned on.

Flags: needinfo?(egao) → needinfo?(aryx.bugmail)

It tests the mach try fuzzy command (bug 1391675) . From looking at the regressor https://hg.mozilla.org/integration/autoland/annotate/ae97a2314ad89d60d89b1f775d21f48798d9de3f/testing/mozbase/moztest/moztest/resolve.py it's not obvious to me what is failing. The failure log references mozilla-central artifacts like https://firefox-ci-tc.services.mozilla.com/api/index/v1/task/gecko.v2.mozilla-central.revision.cdd14a1df784642f8741b0f76041e92ba99ec9df.source.manifest-upload/artifacts/public/manifests.tar.gz but also running a new instance of cram(try) on central still fails

There was a wpt manifest generation task 21 hours ago.

ahal, do you have pointers for Edwin why cram(try) fails?

Flags: needinfo?(aryx.bugmail) → needinfo?(ahal)

These are tests that run mach commands on the shell. You can run it with ./mach cramtest tools/tryselect and they are defined in .t files under tools/tryselect/test.

In this particular case, it looks like after your changes the test is causing the load_wpt_data function in the test resolver to get called which is changing the output of the command (.t tests fail if the stdout changes for any reason).

You could try modifying setup.sh to find a clever way of avoiding the WPT manifest load. Or maybe we need to modify the test.

Flags: needinfo?(ahal) → needinfo?(egao)

I think the easiest might be to either:

  1. redirect the output to sys.stderr (which I think I do already, but not sure now)
  2. suppress the output from manifestupdat within add_wpt_manifest_data entirely
Flags: needinfo?(egao)
Assignee: nobody → egao
Pushed by egao@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/37716ee6bbc1
disable manifestupdate logger so it does not pollute taskgraph generation output r=ahal
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla77

The patch landed on central, this should resolve the issue.

You need to log in before you can comment on or make changes to this bug.