Closed Bug 1633964 Opened 4 months ago Closed 3 months ago

Cleanup FunctionData::atom

Categories

(Core :: JavaScript Engine, task, P2)

task

Tracking

()

RESOLVED FIXED
mozilla77
Tracking Status
firefox77 --- fixed

People

(Reporter: tcampbell, Assigned: tcampbell)

References

Details

Attachments

(2 files)

There is some confusion with the stencil frontend work about explicitName() vs other atoms. I'd like to get it into a consistent state before we make this more complex by updating the NameResolver

The name in the FunctionBox should only hold the explicitName rather than any
sort of implicit or guessed name. Note that any other names still on the
function itself will remain set. This seems to be a minor regression
recently, but only in BinAST.

This is a bit of a lateral change but brings consistency with the
FunctionBox. In the future we will fold proper guessed-atom support into
FunctionBox to allow the NameResolver to work without JSFunctions.

Depends on D72997

Pushed by tcampbell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6ef176eab485
Use explicitName() when creating BinAST FunctionBox. r=mgaudet
https://hg.mozilla.org/integration/autoland/rev/4cffe6e1c9a9
Rename FunctionCreationData::atom to explicitName. r=mgaudet
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla77
You need to log in before you can comment on or make changes to this bug.