Closed Bug 163411 Opened 18 years ago Closed 18 years ago

Render ALT text as tooltip in Quirk Mode

Categories

(SeaMonkey :: General, enhancement)

x86
Windows 98
enhancement
Not set

Tracking

(Not tracked)

CLOSED DUPLICATE of bug 25537

People

(Reporter: danielwang, Assigned: Matti)

Details

First, I must say I DO NOT *want* this. However, there are clearly
*needs* that we do this. We cannot expect every HTML authors out
there to start doing it the right way. The Web has many old pages
that are no longer being maintained but are still revelent to
people, and rendering them as the original authors intended is
essential to people's surfing experience.

Please, if we do add <marquee> support because there are needs
for it (and there are), we must render ALT text in Quirk Mode.
And just so that we do not encourage lame (X)HTML authors continue to
use /quirky/ features, I'll set this bug to be dependent on bug 155482
(and I think all quirky features, <marquee> included, should be
released into trunk builds only after bug 155482 is fixed, but don't
flame me on that :p ).
Depends on: 155482
I understand that you do not want this, I just want to say that it is not even
needed.

I think ALT text should not be rendered as tooltips at all. It is much easier to
evangelize people to use TITLE for ALT than it is to use javascript for
<marquee>. I think evangelism can handle this problem with old sites.

In fact the contrary might be true. Supporting ALT as tooltips in quirks mode
may encourage web authors to use it in future sites. The costs may outweigh the
benefits.

This should be wontfix.
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → WONTFIX
Quirks mode is for the minimum changes absolutely necessary for old pages to not
break. No page will break because you can't see the alternative text as a
tooltip. Verified WONTFIX.
Status: RESOLVED → VERIFIED
I'm very unhappy with the (non-)resolution of bug 163411

I just can't get it, why doctrine must win over usability.

- there is no standards compliance problem: when title is
present it should be clear that only the title attribute is
shown

- the affected pages (having only alt but not title attributes for
img) are (or can be, if not broken for other reasons) perfectly valid
HTML. So it's not a request to render broken pages

- giving the whole fuss a clear thought, it can be argued that the
question, which tooltips are displayed where and when, is not even
in the domain of the HTML REC, it's an application issue not totally
unlike other choices done in the browser's UI

- if you want to hide behind a configuration setting go ahead. what
about
If there's no 'title' for an image, show as tooltip:
[ ] nothing
[ ] URL of image
[ ] size of image
[ ] alt attribute

And for the reason, why this is to be done, I'll quote the 
competition (no, the other one):

http://slashdot.org/comments.pl?sid=38425&cid=4113817
Jonas, All,

Take a look at:
http://www.fwtwr.com/fwtwr/puerto_rico/184game.htm
(and compare using a browser which shows tooltips)

This page is effectively broken when the alt tooltips 
aren't displayed, as they give vital information about
all items on the game board.

And yes, I contacted the author, and he was even positive 
about changing, but has a big practical problem about out it,
because the pages are generated by a program he cannot easily
update. And the pages are generated too often for hand changing.

BTW: Does anybody has XSLT for duplicating the alt attribute of
all img elements into a title attribute?
reopening to mark dupe
Status: VERIFIED → REOPENED
Resolution: WONTFIX → ---
marking dupe

*** This bug has been marked as a duplicate of 25537 ***
Status: REOPENED → RESOLVED
Closed: 18 years ago18 years ago
Resolution: --- → DUPLICATE
verified dupe

Peter Jacobi: I will reply to your comments in that bug.
Status: RESOLVED → VERIFIED
Summary: [RFE] Render ALT text as tooltip in Quirk Mode → Render ALT text as tooltip in Quirk Mode
This isnt a dupe, Is it?
Doesn't matter. This issue is still wontfix.
Status: VERIFIED → CLOSED
No longer depends on: 155482
it doesn't matter but please don't use "closed" :-)
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.