Closed Bug 1634268 Opened 1 year ago Closed 1 year ago

dmabuf-webgl broken, only shows black (Intel Skylake)

Categories

(Core :: Canvas: WebGL, defect, P3)

77 Branch
x86_64
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1634213

People

(Reporter: kubrick, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: nightly-community, regression)

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1632095 +++

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:77.0) Gecko/20100101 Firefox/77.0

Steps to reproduce:

On Linux/wayland with Intel Skylake graphics with
gfx.webrender.all=true
widget.wayland-dmabuf-vaapi.enabled=true
widget.wayland-dmabuf-webgl.enabled=true

Currently testing with 20200429215539, google maps and google earth show a black map, controls are visible though.

This was introduced at the same time as Bug #1632095 and Bug #1632095

so for me this also points to https://bugzilla.mozilla.org/show_bug.cgi?id=1474281

Component: Audio/Video: Playback → Canvas: WebGL
Priority: P5 → --
Regressed by: 1474281
Summary: dmabuf-webgl broken, only shows black → dmabuf-webgl broken, only shows black (Intel Skylake)

Hm can't reproduce this on skylake/nightly, neither with i965 nor with iris. I do however get lot's of Only invalid modifier specified prints in the log, which might gets handled wrong somewhere else in the stack.

Francois, could you provide some more info like the content of about:support (click on Copy text to clipboard there), as well as desktop environment (+version), mesa version and distribution?

Flags: needinfo?(kubrick)

(Please reproduce this bug first, then open about:support, click on "Copy Text to Clipboard" and paste it here. Thanks!)

Severity: normal → minor
Priority: -- → P3
Flags: needinfo?(kubrick)

Driver Vendor: mesa/iris
Driver Version: 20.0.6.0

Just to confirm it: Is the following build black or not?

$ pip3 install --upgrade mozregression
$ GDK_BACKEND=wayland mozregression --repo autoland --launch c3221bde9f2a8057e8058a6a7abfe633a3d01895 --pref gfx.webrender.all:true widget.wayland-dmabuf-webgl.enabled:true -a https://webglsamples.org/aquarium/aquarium.html

Well, I could not reproduce the isse with c3221bde9f2a8057e8058a6a7abfe633a3d01895 ! Pretty sure I had tried the exact same build before, but anyways.
So I was able to fix the issue by restarting in safe mode and then restarting again with extensions enabled. No browser refresh, no pref changed... Really weird.

Safe mode disables hardware rendering and DMABUF.
Make sure you still see "Compositing: WebRender", "Window Protocol: wayland/drm" and Mesa 20 on about:support with DMABUF WebGL enabled:
If above build is grey, I think we can close this as duplicate of bug 1634213.
If DMABUF WebGL works - even with today's Nightly - we could close this bug as invalid.

Just tested myself and I can confirm (although I'm getting grey, not black)

screenshot of the mozregression run (left) and firefox-nightly (right, package 77.0a1.20200420-1 on arch):
https://i.imgur.com/xG4GuAq.png

screenshot of about:support for each:
https://i.imgur.com/EemEijP.png

full about:support json of the broken build (left in the screenshots):
https://paste.mozilla.org/2PjxjqHw

full about:support json of the working build (right in the screenshots):
https://paste.mozilla.org/xEzRLW88

btw I also tested with i965 and I'm getting the exact same results, so I don't think this is an iris/gallium issue

(In reply to Eric Engestrom from comment #7)
Your left Firefox has "Window Protocol: wayland/drm" (dmabuf support), but right one has "Window Protocol: wayland" (no dmabuf support).
I guess your regular Nightly would also be grey if you set widget.wayland-dmabuf-webgl.enabled to true on about:config and restart Nightly, correct?

If regression range of this bug is correct, c3221bde9f2a8057e8058a6a7abfe633a3d01895 is the last (good) commit before bug 1474281.
bug 1474281 was first included in Nightly 2020-04-21.

bug 1634213 says Mesa 20.0.4 is good, 20.0.5 bad. Arch Linux got Mesa 20.0.5 probably on 2020-04-23. I assume you (maybe you both) are seeing that bug. It was confirmed upstream.

You are correct on all accounts :)

I tested the Mesa fix and it solves the issue, so I think the Firefox bug can be closed as NOTOURBUG 👍

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1634213

I apologise for the very messy way I handled this bug & responses, but no it's not fixed for me. mozregression had started firefox with X11...
I have applied https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/4861 but it doesn't fix the issue. Webgl content doesn't appear.

Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
Status: REOPENED → UNCONFIRMED
Ever confirmed: false

I really seems to be a mesa issue though, as reverting to 20.0.4 fixes the issue, I have mentionned that in the upstream bug report.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago1 year ago
No longer regressed by: 1474281
Resolution: --- → DUPLICATE
Duplicate of bug: 1634213

For ref, it took a while but widget.wayland-dmabuf-webgl.enabled can finally be used on the 20.0 mesa branch again https://gitlab.freedesktop.org/mesa/mesa/-/issues/2882#note_509975

You need to log in before you can comment on or make changes to this bug.