Closed Bug 1634345 Opened 4 months ago Closed 4 months ago

Perma [Searchfox idx] /builds/worker/checkouts/gecko/build/clang-plugin/mozsearch-plugin/MozsearchIndexer.cpp:201:40: error: no template named 'make_unique' in namespace 'std'; did you mean 'llvm::make_unique'?

Categories

(Webtools :: Searchfox, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Regression)

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell fixed:backout])

Filed by: apavel [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=300181050&repo=mozilla-central
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/Eh2fYEctQMyfXelwY7QFYA/runs/0/artifacts/public/logs/live_backing.log


[task 2020-04-30T10:04:34.891Z] 10:04:34 INFO - /builds/worker/fetches/clang/bin/clang++ --gcc-toolchain=/builds/worker/fetches/clang -std=gnu++17 -o host_OverrideBaseCallUsageChecker.o -c -I/builds/worker/fetches/clang/include -std=c++11 -fno-exceptions -fno-rtti -D_GNU_SOURCE -D__STDC_CONSTANT_MACROS -D__STDC_FORMAT_MACROS -D__STDC_LIMIT_MACROS -fno-rtti -fno-exceptions -O3 -DDEBUG=1 -fPIC -I/builds/worker/checkouts/gecko/build/clang-plugin -I/builds/worker/checkouts/gecko/obj-arm-unknown-linux-androideabi/build/clang-plugin -I/builds/worker/checkouts/gecko/obj-arm-unknown-linux-androideabi/dist/include -MD -MP -MF .deps/host_OverrideBaseCallUsageChecker.o.pp -I/builds/worker/checkouts/gecko/obj-arm-unknown-linux-androideabi/dist/include/nspr /builds/worker/checkouts/gecko/build/clang-plugin/OverrideBaseCallUsageChecker.cpp
[task 2020-04-30T10:04:34.891Z] 10:04:34 INFO - make[4]: Leaving directory '/builds/worker/checkouts/gecko/obj-arm-unknown-linux-androideabi/build/clang-plugin'
[task 2020-04-30T10:04:36.969Z] 10:04:36 INFO - make[4]: Entering directory '/builds/worker/checkouts/gecko/obj-arm-unknown-linux-androideabi/build/clang-plugin'
[task 2020-04-30T10:04:36.970Z] 10:04:36 INFO - /builds/worker/fetches/clang/bin/clang++ --gcc-toolchain=/builds/worker/fetches/clang -std=gnu++17 -o host_ParamTraitsEnumChecker.o -c -I/builds/worker/fetches/clang/include -std=c++11 -fno-exceptions -fno-rtti -D_GNU_SOURCE -D__STDC_CONSTANT_MACROS -D__STDC_FORMAT_MACROS -D__STDC_LIMIT_MACROS -fno-rtti -fno-exceptions -O3 -DDEBUG=1 -fPIC -I/builds/worker/checkouts/gecko/build/clang-plugin -I/builds/worker/checkouts/gecko/obj-arm-unknown-linux-androideabi/build/clang-plugin -I/builds/worker/checkouts/gecko/obj-arm-unknown-linux-androideabi/dist/include -MD -MP -MF .deps/host_ParamTraitsEnumChecker.o.pp -I/builds/worker/checkouts/gecko/obj-arm-unknown-linux-androideabi/dist/include/nspr /builds/worker/checkouts/gecko/build/clang-plugin/ParamTraitsEnumChecker.cpp
[task 2020-04-30T10:04:36.970Z] 10:04:36 INFO - make[4]: Leaving directory '/builds/worker/checkouts/gecko/obj-arm-unknown-linux-androideabi/build/clang-plugin'
[task 2020-04-30T10:04:37.779Z] 10:04:37 INFO - make[4]: Entering directory '/builds/worker/checkouts/gecko/obj-arm-unknown-linux-androideabi/build/clang-plugin'
[task 2020-04-30T10:04:37.780Z] 10:04:37 INFO - /builds/worker/fetches/clang/bin/clang++ --gcc-toolchain=/builds/worker/fetches/clang -std=gnu++17 -o host_RefCountedCopyConstructorChecker.o -c -I/builds/worker/fetches/clang/include -std=c++11 -fno-exceptions -fno-rtti -D_GNU_SOURCE -D__STDC_CONSTANT_MACROS -D__STDC_FORMAT_MACROS -D__STDC_LIMIT_MACROS -fno-rtti -fno-exceptions -O3 -DDEBUG=1 -fPIC -I/builds/worker/checkouts/gecko/build/clang-plugin -I/builds/worker/checkouts/gecko/obj-arm-unknown-linux-androideabi/build/clang-plugin -I/builds/worker/checkouts/gecko/obj-arm-unknown-linux-androideabi/dist/include -MD -MP -MF .deps/host_RefCountedCopyConstructorChecker.o.pp -I/builds/worker/checkouts/gecko/obj-arm-unknown-linux-androideabi/dist/include/nspr /builds/worker/checkouts/gecko/build/clang-plugin/RefCountedCopyConstructorChecker.cpp
[task 2020-04-30T10:04:37.780Z] 10:04:37 INFO - make[4]: Leaving directory '/builds/worker/checkouts/gecko/obj-arm-unknown-linux-androideabi/build/clang-plugin'
[task 2020-04-30T10:04:38.076Z] 10:04:38 INFO - make[4]: Entering directory '/builds/worker/checkouts/gecko/obj-arm-unknown-linux-androideabi/build/clang-plugin'
[task 2020-04-30T10:04:38.076Z] 10:04:38 INFO - /builds/worker/fetches/clang/bin/clang++ --gcc-toolchain=/builds/worker/fetches/clang -std=gnu++17 -o host_MozsearchIndexer.o -c -I/builds/worker/fetches/clang/include -std=c++11 -fno-exceptions -fno-rtti -D_GNU_SOURCE -D__STDC_CONSTANT_MACROS -D__STDC_FORMAT_MACROS -D__STDC_LIMIT_MACROS -fno-rtti -fno-exceptions -O3 -DDEBUG=1 -fPIC -I/builds/worker/checkouts/gecko/build/clang-plugin -I/builds/worker/checkouts/gecko/obj-arm-unknown-linux-androideabi/build/clang-plugin -I/builds/worker/checkouts/gecko/obj-arm-unknown-linux-androideabi/dist/include -MD -MP -MF .deps/host_MozsearchIndexer.o.pp -I/builds/worker/checkouts/gecko/obj-arm-unknown-linux-androideabi/dist/include/nspr /builds/worker/checkouts/gecko/build/clang-plugin/mozsearch-plugin/MozsearchIndexer.cpp
[task 2020-04-30T10:04:38.077Z] 10:04:38 ERROR - /builds/worker/checkouts/gecko/build/clang-plugin/mozsearch-plugin/MozsearchIndexer.cpp:201:40: error: no template named 'make_unique' in namespace 'std'; did you mean 'llvm::make_unique'?
[task 2020-04-30T10:04:38.077Z] 10:04:38 INFO - std::unique_ptr<FileInfo> Info = std::make_unique<FileInfo>(Absolute);
[task 2020-04-30T10:04:38.077Z] 10:04:38 INFO - ^~~~~~~~~~~~~~~~
[task 2020-04-30T10:04:38.077Z] 10:04:38 INFO - llvm::make_unique
[task 2020-04-30T10:04:38.077Z] 10:04:38 INFO - /builds/worker/fetches/clang/include/llvm/ADT/STLExtras.h:1405:1: note: 'llvm::make_unique' declared here
[task 2020-04-30T10:04:38.077Z] 10:04:38 INFO - make_unique(Args &&... args) {
[task 2020-04-30T10:04:38.077Z] 10:04:38 INFO - ^
[task 2020-04-30T10:04:38.077Z] 10:04:38 ERROR - /builds/worker/checkouts/gecko/build/clang-plugin/mozsearch-plugin/MozsearchIndexer.cpp:201:40: error: no template named 'make_unique' in namespace 'std'; did you mean 'llvm::make_unique'?
[task 2020-04-30T10:04:38.078Z] 10:04:38 INFO - std::unique_ptr<FileInfo> Info = std::make_unique<FileInfo>(Absolute);
[task 2020-04-30T10:04:38.078Z] 10:04:38 INFO - ^~~~~~~~~~~~~~~~
[task 2020-04-30T10:04:38.078Z] 10:04:38 INFO - llvm::make_unique
[task 2020-04-30T10:04:38.078Z] 10:04:38 INFO - /builds/worker/fetches/clang/include/llvm/ADT/STLExtras.h:1405:1: note: 'llvm::make_unique' declared here
[task 2020-04-30T10:04:38.078Z] 10:04:38 INFO - make_unique(Args &&... args) {
[task 2020-04-30T10:04:38.078Z] 10:04:38 INFO - ^
[task 2020-04-30T10:04:38.078Z] 10:04:38 ERROR - /builds/worker/checkouts/gecko/build/clang-plugin/mozsearch-plugin/MozsearchIndexer.cpp:455:9: error: no template named 'make_unique' in namespace 'std'; did you mean 'llvm::make_unique'?
[task 2020-04-30T10:04:38.078Z] 10:04:38 INFO - std::make_unique<PreprocessorHook>(this));
[task 2020-04-30T10:04:38.078Z] 10:04:38 INFO - ^~~~~~~~~~~~~~~~
[task 2020-04-30T10:04:38.078Z] 10:04:38 INFO - llvm::make_unique
[task 2020-04-30T10:04:38.079Z] 10:04:38 INFO - /builds/worker/fetches/clang/include/llvm/ADT/STLExtras.h:1405:1: note: 'llvm::make_unique' declared here
[task 2020-04-30T10:04:38.079Z] 10:04:38 INFO - make_unique(Args &&... args) {
[task 2020-04-30T10:04:38.079Z] 10:04:38 INFO - ^
[task 2020-04-30T10:04:38.079Z] 10:04:38 ERROR - /builds/worker/checkouts/gecko/build/clang-plugin/mozsearch-plugin/MozsearchIndexer.cpp:455:9: error: no template named 'make_unique' in namespace 'std'; did you mean 'llvm::make_unique'?
[task 2020-04-30T10:04:38.079Z] 10:04:38 INFO - std::make_unique<PreprocessorHook>(this));
[task 2020-04-30T10:04:38.079Z] 10:04:38 INFO - ^~~~~~~~~~~~~~~~
[task 2020-04-30T10:04:38.079Z] 10:04:38 INFO - llvm::make_unique
[task 2020-04-30T10:04:38.079Z] 10:04:38 INFO - /builds/worker/fetches/clang/include/llvm/ADT/STLExtras.h:1405:1: note: 'llvm::make_unique' declared here
[task 2020-04-30T10:04:38.079Z] 10:04:38 INFO - make_unique(Args &&... args) {
[task 2020-04-30T10:04:38.080Z] 10:04:38 INFO - ^
[task 2020-04-30T10:04:38.080Z] 10:04:38 ERROR - /builds/worker/checkouts/gecko/build/clang-plugin/mozsearch-plugin/MozsearchIndexer.cpp:1633:12: error: no template named 'make_unique' in namespace 'std'; did you mean 'llvm::make_unique'?

Ricky please take a look.

Flags: needinfo?(rstewart)
Regressed by: 1631399
Product: Firefox Build System → Developer Services

This is going to prevent searchfox from indexing latest m-c so it's a blocker for searchfox.

Component: General → Searchfox
Priority: P5 → P2
Product: Developer Services → Webtools
Version: unspecified → other

From the compilation command in comment 0 it looks like we're compiling with -std=c++11 which would explain this. I'm not sure where that's coming from, and I suspect fixing that may take some digging and/or testing. In the meantime maybe we should back out the regressing patch.

It was backed out, so I'm clearing the needinfo request.

Flags: needinfo?(rstewart)

We can mark this fixed by backout.

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Whiteboard: [stockwell fixed:backout]
You need to log in before you can comment on or make changes to this bug.