Crash can occur when closing Page Setup dialog [@ SetOrigin]

VERIFIED FIXED

Status

Camino Graveyard
Printing
--
critical
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: Chris Petersen, Assigned: Conrad Carlen (not reading bugmail))

Tracking

({crash})

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Build: 2002-08-17-08
Platform: OS X 10.2 
Expected Results: Page setup dialog should close
What I got: Crash occurs

Steps to reproduce:

1) Launch Chimera
2) Close browser window 
3) Go to Navigator - Preferences. Click on Navigation - History tab. Press Clear
Disk Cache and close this window.
4) Now, select Page setup from File menu.
5) Click Cancel or OK to close dialog. Crash should occur.

This seems to be a 10.2 (6c115) issue since I can't reproduce these same steps
under 10.1.5.
(Reporter)

Comment 1

16 years ago
Created attachment 95851 [details]
stack trace

Updated

16 years ago
Severity: normal → critical
Keywords: crash
Summary: Crash can occur when closing Page Setup dialog → Crash can occur when closing Page Setup dialog [@ SetOrigin]
(Reporter)

Comment 2

16 years ago
I'm able to reproduce this problem with fewer steps as described:

1) Select a bookmark and use the Get Info command.
2) After Get Info panel appears, close the exist browser window.
3) Select File - Page Setup. Click OK. Crash should occur.

Comment 3

16 years ago
Hopefully my fix for bug 177369 will have fixed this.
(Reporter)

Comment 4

16 years ago
Using the 2002-10-30-04 build, this problem is still occuring using comments #2.
Tested under 10.2.1.
(Reporter)

Updated

16 years ago
Blocks: 147975
QA Contact: winnie → sairuh

Comment 5

16 years ago
This may have been fixed by ccarlen's page setup work.  Or may be fixed cause
the Page Setup menu item is disabled for mw when I have no window open.  Marking
FIXED  .
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

16 years ago
Marking verified since Page Setup menu item is now dimmed under these
conditions.  Verified with 2002-11-22-04.
Status: RESOLVED → VERIFIED
No longer blocks: 147975
Crash Signature: [@ SetOrigin]
You need to log in before you can comment on or make changes to this bug.