Closed Bug 1634922 Opened 5 months ago Closed 5 months ago

welcome_help.xhtml IRC ("Realtime Chat") link still points to moznet

Categories

(SeaMonkey :: Help Documentation, defect)

defect

Tracking

(seamonkey2.53+ fixed, seamonkey2.57esr? affected)

RESOLVED FIXED
seamonkey 2.74
Tracking Status
seamonkey2.53 + fixed
seamonkey2.57esr ? affected

People

(Reporter: nunojsg, Assigned: nunojsg)

Details

(Whiteboard: SM2.53.3)

User Story

LangPacks which might need to be checked: cs, en-US, es-AR, fi,fr, hu, it, ja, ka, nb-NO, nl, pt-BT, pt-PT, ru, sk, sv, zh-CN, zu-TW.


Probably  fixed with this Bug for de,  en-US, es

Attachments

(2 files, 2 obsolete files)

The SeaMonkey Help welcome page has a "Realtime Chat" link which points to the old project channel on moznet.

Attachment #9145259 - Flags: review?(iann_bugzilla)

Steps how to reproduce with installation of official De SeaMonkey 2.53.2 beta 1 Mozilla/5.0 (NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0 Build 20200402090541 (Default Classic Theme, my normal created User Profile) on German WIN7 64bit

  1. Launch Browser
  2. <f1> for Help
    » WELCOME Help page appears
  3. Click "Realtime Chat" heading with link
    » Expected: opens irc://freenode/SeaMonkey
    Bug: leads to to irc://moznet/ (irc://irc.mozilla.org/) 😥

Additional information:
a) Problem also is visible in source file from seamonkey-2.53.2b1.en-US.langpack.xpi, which contains the link to irc://moznet/ (irc://irc.mozilla.org/)
b) This problem also affects German Language pack, probably all language packs

Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → All
Hardware: Unspecified → All
Assignee: nobody → nunojsg
Status: NEW → ASSIGNED
Comment on attachment 9145259 [details] [diff] [review]
welcome_help.xhtml freenode patch

[Triage Comment]
LGTM r/a=me
Attachment #9145259 - Flags: review?(iann_bugzilla)
Attachment #9145259 - Flags: review+
Attachment #9145259 - Flags: approval-comm-release+
Attachment #9145259 - Flags: approval-comm-esr60+

Can you do a suitable patch for l10n too, thanks?

Flags: needinfo?(nunojsg)

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/638381d6d1ea
Update IRC link (moznet->freenode). r=IanN

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED

This patch replaces most moznet IRC URLs (in welcome_help.xhtml) with the freenode #SeaMonkey one.

There are two links left untouched in es-AR and es-ES, to irc://irc.mozilla.org/mozilla-hispano.

Flags: needinfo?(nunojsg)
Attachment #9145326 - Flags: feedback?(iann_bugzilla)

RickieES, do you happen to know if there is a replacement for #mozilla-hispano? (That IRC channel is also listed in https://www.mozilla-hispano.org/documentacion/Recursos_para_colaboradores.)

Flags: needinfo?(rpmdisguise-nave)
Comment on attachment 9145326 [details] [diff] [review]
l10n welcome_help.xhtml freenode patch

Thanks, looks good
Attachment #9145326 - Flags: feedback?(iann_bugzilla) → feedback+
Target Milestone: --- → seamonkey 2.74

(In reply to Nuno Silva from comment #6)

RickieES, do you happen to know if there is a replacement for #mozilla-hispano? (That IRC channel is also listed in https://www.mozilla-hispano.org/documentacion/Recursos_para_colaboradores.)

Mozilla Hispano has switched to Riot/Matrix, so there is no IRC replacement. And, AFAIK, the web interface for Riot or Neo does not load at all in SeaMonkey. It seems sensible to remove the whole sentence.

Flags: needinfo?(rpmdisguise-nave)

(In reply to RickieES aka Ricardo Palomares from comment #8)

(In reply to Nuno Silva from comment #6)

RickieES, do you happen to know if there is a replacement for #mozilla-hispano? (That IRC channel is also listed in https://www.mozilla-hispano.org/documentacion/Recursos_para_colaboradores.)

Mozilla Hispano has switched to Riot/Matrix, so there is no IRC replacement. And, AFAIK, the web interface for Riot or Neo does not load at all in SeaMonkey. It seems sensible to remove the whole sentence.

That should be fixed in 2.53.2, chat.mozilla.org moans that it is not a supported browser but lets you click through and login.
The link for the room on Matrix should be https://chat.mozilla.org/#/room/#mozilla-hispano:mozilla.org

Thanks;

As it is not IRC anymore, but still works with Seamonkey, perhaps it could be shown as a separate item, like this? (If it is still valid Spanish, of course.)

It is perfect, thank you very much.

(In reply to Ian Neal from comment #9)

That should be fixed in 2.53.2, chat.mozilla.org moans that it is not a supported browser but lets you click through and login.
The link for the room on Matrix should be https://chat.mozilla.org/#/room/#mozilla-hispano:mozilla.org

So it is. Works a little bumpy, but at least some basic functions already do work, as you can see here
https://unofficialseamonkeynews.files.wordpress.com/2020/05/riot-screenshot.png
and here
https://unofficialseamonkeynews.files.wordpress.com/2020/05/mozklla-riot-screenshot.png

Comment on attachment 9146411 [details] [diff] [review]
es-ES draft patch to update mozilla-hispano chat link

Let's ask someone who knows ;)
Attachment #9146411 - Flags: feedback?(rpmdisguise-nave)
Comment on attachment 9146411 [details] [diff] [review]
es-ES draft patch to update mozilla-hispano chat link

Review of attachment 9146411 [details] [diff] [review]:
-----------------------------------------------------------------

Confirmed with Mozilla Hispano guys, the chat at Matrix is intended to fully replace the IRC channel, so it is OK to replace it in the help file, which is itself correct. Thank you very much!
Attachment #9146411 - Flags: feedback?(rpmdisguise-nave) → feedback+

A new l10n patch which now also updates the mozilla-hispano chat links in es-ES and es-AR.

Attachment #9145326 - Attachment is obsolete: true
Attachment #9146411 - Attachment is obsolete: true
Comment on attachment 9146623 [details] [diff] [review]
l10n welcome_help.xhtml freenode patch v2

[Triage Comment]
LGTM r/a=me
Attachment #9146623 - Flags: review+
Attachment #9146623 - Flags: approval-comm-release+
Attachment #9146623 - Flags: approval-comm-esr60+

I found this obsolete information in several LangPacks (see User Story), for many of them patch for Bug 1634922 might work, because they simply use the en-US text.

How can we get the fix reliably to all Languages?

User Story: (updated)
Whiteboard: SM2.53.3
You need to log in before you can comment on or make changes to this bug.