heigth of an absolute positioned div's containing box calculated incorrectly

RESOLVED INVALID

Status

()

RESOLVED INVALID
16 years ago
16 years ago

People

(Reporter: dthoma, Assigned: attinasi)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.0.0) Gecko/20020623 Debian/1.0.0-0.woody.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.0.0) Gecko/20020623 Debian/1.0.0-0.woody.1

Example:

<div style="position:absolute; top:0px; left:0px; border:#ff0000 2px solid;">
<div style="position:absolute; top:0px; left:0px; height:200px">
text
</div>
</div>

The height of the outer div should be 200px according to the definition at:
http://www.w3.org/TR/REC-CSS2/visudet.html#abs-non-replaced-height

But mozilla sets the height to 0px.


Reproducible: Always

Steps to Reproduce:

Updated

16 years ago
QA Contact: petersen → amar

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 118940 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
that's a table bug.  This is not.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
This _is_ invalid however.  The inner div is out-of-flow and should not affect
the parent height....  This falls under item 4 at
http://www.w3.org/TR/REC-CSS2/visudet.html#abs-non-replaced-height:

  4. If at this point both 'margin-top' and 'margin-bottom' are still 'auto',
     solve the equation under the extra constraint that the two margins must get
     equal values.

The margin values are equal and negative in this case.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.