Closed Bug 1635394 Opened 2 years ago Closed 2 years ago

Crash in [@ mozilla::dom::WorkerPrivate::OnProcessNextEvent | mozilla::dom::WorkerThread::Observer::OnProcessNextEvent | NS_ProcessPendingEvents]

Categories

(Core :: DOM: Workers, defect)

Unspecified
Windows 10
defect

Tracking

()

RESOLVED DUPLICATE of bug 1634259
Tracking Status
firefox77 --- wontfix
firefox78 --- fixed

People

(Reporter: achronop, Unassigned)

References

(Regression)

Details

(Keywords: crash, regression)

Crash Data

This bug is for crash report bp-352a0a8b-3250-4b4b-a204-dbcf30200501.

Top 10 frames of crashing thread:

0 xul.dll mozilla::dom::WorkerPrivate::OnProcessNextEvent dom/workers/WorkerPrivate.cpp:2988
1 xul.dll mozilla::dom::WorkerThread::Observer::OnProcessNextEvent dom/workers/WorkerThread.cpp:356
2 xul.dll nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1107
3 xul.dll NS_ProcessPendingEvents xpcom/threads/nsThreadUtils.cpp:429
4 xul.dll mozilla::dom::WorkerPrivate::ClearMainEventQueue dom/workers/WorkerPrivate.cpp:3518
5 xul.dll mozilla::dom::WorkerPrivate::ScheduleDeletion dom/workers/WorkerPrivate.cpp:3363
6 xul.dll mozilla::dom::workerinternals::`anonymous namespace'::WorkerThreadPrimaryRunnable::Run dom/workers/RuntimeService.cpp:2334
7 xul.dll nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1200
8 xul.dll NS_ProcessNextEvent xpcom/threads/nsThreadUtils.cpp:481
9 xul.dll mozilla::ipc::MessagePumpForNonMainThreads::Run ipc/glue/MessagePump.cpp:332

It has started regressing to all platforms since 20200430082621. It is not very clear report but it has a clear regressed day.

Component: XPConnect → DOM: Workers

Base on the stack and the date, I'm going to guess this could be fallout from bug 1594572.

Flags: needinfo?(kmaglione+bmo)
Keywords: regression
Regressed by: 1594572
Has Regression Range: --- → yes
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1634259
Flags: needinfo?(kmaglione+bmo)
You need to log in before you can comment on or make changes to this bug.