Closed Bug 1635734 Opened 3 months ago Closed 3 months ago

Chat broken in Thunderbird 77 beta for macOS

Categories

(Chat Core :: General, defect, P1)

Unspecified
macOS

Tracking

(thunderbird77 fixed)

VERIFIED FIXED
Instantbird 78
Tracking Status
thunderbird77 --- fixed

People

(Reporter: clokep, Assigned: khushil324)

Details

(Keywords: regression, regressionwindow-wanted, Whiteboard: smoketestbeta)

Attachments

(1 file)

Just updated to Thunderbird 77 beta 1 and chat is broken. It will not connect. I see the following errors when trying to connect an IRC account:

this._outputStream is undefined socket.jsm:271
    sendString resource:///modules/socket.jsm:271
    sendRawMessage resource:///modules/irc.jsm:2101
    sendMessage resource:///modules/irc.jsm:2059
    quit resource:///modules/irc.jsm:1886
    disconnect resource:///modules/irc.jsm:1905
    disconnect resource:///modules/imAccounts.jsm:884
    disconnect chrome://messenger/content/chat/imAccounts.js:256
    oncommand chrome://messenger/content/chat/imAccounts.xhtml:1
TypeError: browser is null
hiddenWindow.jsm:21:5
NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "browser is null" {file: "resource:///modules/hiddenWindow.jsm" line: 21}]'[JavaScript Error: "browser is null" {file: "resource:///modules/hiddenWindow.jsm" line: 21}]' when calling method: [prplIAccount::connect] imAccounts.jsm:878
    connect resource:///modules/imAccounts.jsm:878
    connect chrome://messenger/content/chat/imAccounts.js:249
    oncommand chrome://messenger/content/chat/imAccounts.xhtml:1
Whiteboard: smoketestbeta

Hmm, I'm connected to #thunderbird-otr with nightly and that seems to work

(In reply to Magnus Melin [:mkmelin] from comment #1)

Hmm, I'm connected to #thunderbird-otr with nightly and that seems to work

The hiddenWindow errors point to this probably being macOS only.

Would make sense. Khushil, do you see this?

OS: Unspecified → macOS
Summary: Chat broken in Thunderbird 77 beta → Chat broken in Thunderbird 77 beta for macOS

I am not on trunk. I am updating it and will work on the bug ASAP.

This issue is related to missing the following lines from hiddenWindow.xhtml:

#ifdef MOZ_OPENPGP
<!ENTITY % bondOpenPGPDTD SYSTEM "chrome://openpgp/content/strings/bond.dtd">
%bondOpenPGPDTD;
#endif

Should I create a patch for this and then start working on bug 1635734 or just add this thing in the patch for that bug?

Assignee: nobody → khushil324
Attachment #9146544 - Flags: review?(clokep)
Status: NEW → ASSIGNED
Comment on attachment 9146544 [details] [diff] [review]
Bug-1635734_fix-broken-chat-0.patch

Review of attachment 9146544 [details] [diff] [review]:
-----------------------------------------------------------------

This looks reasonable, but not 100% confident on it.
Attachment #9146544 - Flags: review?(clokep) → review+

(In reply to Patrick Cloke [:clokep] from comment #7)

This looks reasonable, but not 100% confident on it.

Have you tried the patch? Any problems?

It's not the first time that there's a hidden window bustage; could someone write an automated test to ensure it's working correctly?

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/c5def570bb4b
Fix Chat broken in Thunderbird for macOS. r=clokep

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Instantbird 78
Comment on attachment 9146544 [details] [diff] [review]
Bug-1635734_fix-broken-chat-0.patch

[Approval Request Comment]
Regression caused by (bug #): Likely bug 1631198 or bug 1631247
User impact if declined: Chat doesn't work on macOS
Testing completed (on c-c, etc.): None
Risk to taking this patch (and alternatives if risky): I don't think this will break things more. :)
Attachment #9146544 - Flags: approval-comm-beta?
Comment on attachment 9146544 [details] [diff] [review]
Bug-1635734_fix-broken-chat-0.patch

Thank for the patch
Attachment #9146544 - Flags: approval-comm-beta? → approval-comm-beta+

Verified in 77.0b2 that this is fixed! Thanks!

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.