Closed Bug 1636059 Opened 2 years ago Closed 2 years ago

Warp: use template objects for NewArray and NewObject JSOps

Categories

(Core :: JavaScript Engine: JIT, task, P1)

task

Tracking

()

RESOLVED FIXED
mozilla78
Tracking Status
firefox78 --- fixed

People

(Reporter: jandem, Assigned: jandem)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Right now we just do a VM call but we can match IonBuilder by using Baseline's template objects.

The use of JSObject* likely goes back to unboxed arrays.

Severity: normal → N/A
Priority: -- → P1
Duplicate of this bug: 1629570
Pushed by jdemooij@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5dfe569548a8
part 1 - Use ArrayObject* instead of JSObject* in the NewArray code. r=iain
https://hg.mozilla.org/integration/autoland/rev/de593166a446
part 2 - Use template objects for NewArray and NewObject. r=iain
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78
You need to log in before you can comment on or make changes to this bug.