Open Bug 1636063 Opened 4 years ago Updated 3 years ago

Calls between are not working properly on Firefox


(Core :: WebRTC, defect, P3)




Tracking Status
firefox76 --- affected
firefox77 --- affected
firefox78 --- affected
firefox81 --- unaffected
firefox82 --- unaffected
firefox83 --- unaffected
firefox86 --- affected
firefox87 --- affected
firefox88 --- affected


(Reporter: cfogel, Unassigned)



(2 files)

Affected versions

  • 77.0b2, 76.0

Affected platforms

  • Windows 10, Ubuntu 18;

Steps to reproduce

  1. Launch Firefox on 2 workstations;
  2. Try to login on on both;
  3. Start a call between the tho machines;

Expected result

  • call goes through without issues;

Actual result

  • call is initiated but sound and video is not displayed to the other person in call;

Regression range

  • initial assessment points to issue as not being a regression but (probably) a website compat issue.

Aditional info

  • noticed with :cbaica durring webcompat testing;
  • issue not encountered on Chrome.
Has Regression Range: --- → no
Has STR: --- → yes

Because this bug's Severity is normal and has not been changed, and this bug's priority is -- (none,) indicating it has has not been previously triaged, the bug's Severity is being updated to -- (default, untriaged.)

Severity: normal → --

This is working for me, Linux <-> OS X, Cristian, could you please re-test and see if there is still a problem? Thanks!

Flags: needinfo?(cristian.fogel)

Still not working after making cross-calls between macOS 10.15.3 <> Ubuntu 20 on 78.0a1 (2020-05-12), 77.0b5.

Flags: needinfo?(cristian.fogel)

Not sure why it would work for me but not for you. Could you please attach an about:webrtc from a failed call? Thanks!

Severity: -- → S3
Priority: -- → P3
Attached file aboutWebrtc.html

Attaching from macOS device.
If it's of any help, managed to get it working for 2 sessions with calling from macOS -> Windows 10 but it did not work when trying from macOS -> Ubuntu

Attached file aboutWebrtc.html

Attached here, is the file from the Ubuntu OS machine.

QA Whiteboard: [qa-regression-triage]

Managed to revisit this issue.
Tried connections between: Win 10 - macOS 11.0, Win 10 - Ubuntu 18 and vice-versa with current RC & Nightly builds.

As it stands, the connections worked without any issues and both audio video was working without any issue.
Closing the reports as WFM, will keep an eye out and reopen if the issue resurfaces somehow.

Closed: 4 years ago
Resolution: --- → WORKSFORME

Change the status for beta to have the same as nightly and release.
For more information, please visit auto_nag documentation.

I will reopen this bug because I was able to reproduce this issue on Win 10 - macOS 10.15 on the latest Firefox versions(release, beta and nightly).

Resolution: WORKSFORME → ---
You need to log in before you can comment on or make changes to this bug.