Closed Bug 1636119 Opened 3 months ago Closed 3 months ago

jump when css animation starts and stops

Categories

(Core :: SVG, defect, P3)

68 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla78
Tracking Status
firefox-esr68 --- wontfix
firefox75 --- wontfix
firefox76 --- wontfix
firefox77 --- wontfix
firefox78 --- fixed

People

(Reporter: kusmabite, Assigned: longsonr)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:75.0) Gecko/20100101 Firefox/75.0

Steps to reproduce:

Visit https://kusma.pages.freedesktop.org/, and hover the mouse cursor over the
jumbotron (where the gears are)

Actual results:

When the gears started spinning, some of them performed a small jump.

Expected results:

The gears should have rotated in place. This behaves correctly on Chromium and Edge.

Just FYI: this is a work-in-progress updated version of https://www.mesa3d.org/, I'm submitting so there's a chance of this working nicely by the time we go live with it.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Layout
Product: Firefox → Core
Attached file reduced.html

Regression window:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=93075ec49df3982c26873b822d762bd3d8863fad&tochange=9b83eeea8a82e2c638b7be5f47a7b73f6267a17d

Suspect:
5830f058ab4ef321e8f0ccf65a236ced21ee05fd violet — Bug 1523343 - Should not round translation for SVG frame r=longsonr

Status: UNCONFIRMED → NEW
Component: Layout → SVG
Ever confirmed: true
Keywords: regression
Regressed by: 1523343
Version: 75 Branch → 68 Branch
Assignee: nobody → longsonr
Status: NEW → ASSIGNED

Because this bug's Severity is normal and has not been changed, and this bug's priority is -- (none,) indicating it has has not been previously triaged, the bug's Severity is being updated to -- (default, untriaged.)

Severity: normal → --
Severity: -- → S4
Priority: -- → P3
Target Milestone: --- → mozilla78
Blocks: 1561225
Pushed by longsonr@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/02e266dc4a3d
Don't snap SVG content during animation r=hiro
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Blocks: 1625422
QA Whiteboard: [qa-78b-p2]

Just want to update the repro-link here. I've since learning that this is related to pixel-snapping, worked around this issue on the URL posted. To be able to test this in the future, I've added this link to point to the old version:

https://kusma.pages.freedesktop.org/firefox-repro/

You need to log in before you can comment on or make changes to this bug.