Closed Bug 1636122 Opened 3 months ago Closed 3 months ago

Crash in [@ rx::Clear11::clearFramebuffer]

Categories

(Core :: Canvas: WebGL, defect)

Unspecified
Windows
defect

Tracking

()

RESOLVED FIXED
mozilla78
Tracking Status
firefox-esr68 --- unaffected
firefox75 --- unaffected
firefox76 --- unaffected
firefox77 --- unaffected
firefox78 + fixed

People

(Reporter: jcristau, Assigned: jgilbert)

References

(Regression)

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug is for crash report bp-e7ff311f-0c62-4bf5-a8f1-16bde0200507.

Top 10 frames of crashing thread:

0 libglesv2.dll rx::Clear11::clearFramebuffer gfx/angle/checkout/src/libANGLE/renderer/d3d/d3d11/Clear11.cpp:525
1 libglesv2.dll rx::Framebuffer11::clearImpl gfx/angle/checkout/src/libANGLE/renderer/d3d/d3d11/Framebuffer11.cpp
2 libglesv2.dll rx::FramebufferD3D::clear gfx/angle/checkout/src/libANGLE/renderer/d3d/FramebufferD3D.cpp:104
3 libglesv2.dll gl::Framebuffer::clear gfx/angle/checkout/src/libANGLE/Framebuffer.cpp:1367
4 libglesv2.dll gl::Context::clear gfx/angle/checkout/src/libANGLE/Context.cpp:3645
5 xul.dll mozilla::gl::GLContext::raw_fClear gfx/gl/GLContext.h:891
6 xul.dll mozilla::WebGLContext::ValidateAndInitFB dom/canvas/WebGLContext.cpp:1304
7 xul.dll mozilla::WebGLContext::BindCurFBForDraw dom/canvas/WebGLContext.cpp:1319
8 xul.dll mozilla::ValidateDraw dom/canvas/WebGLContextDraw.cpp:332
9 xul.dll mozilla::WebGLContext::DrawArraysInstanced dom/canvas/WebGLContextDraw.cpp:639

This signature is newly showing up in nightly 20200507085231.

Flags: needinfo?(jgilbert)
Regressed by: 1633628

Yep, this is very likely to be caused by bug 1633628.

We probably just need a null check because I guess the blend state can be null (default)

Status: NEW → RESOLVED
Closed: 3 months ago
Flags: needinfo?(jgilbert)
Resolution: --- → FIXED
Target Milestone: --- → mozilla78

This signature came back (at lower volume) after the new patch landed in bug 1633628.

Flags: needinfo?(jmuizelaar)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Assignee: nobody → jgilbert
Pushed by jmuizelaar@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/040a6d3c401d
[angle] Use deviceContext instead of deviceContext1. r=jrmuizel
Status: REOPENED → RESOLVED
Closed: 3 months ago3 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.