Closed Bug 1636533 Opened 9 months ago Closed 8 months ago

Improve address book deletion prompts

Categories

(SeaMonkey :: MailNews: Address Book & Contacts, enhancement)

enhancement

Tracking

(seamonkey2.49esr wontfix, seamonkey2.53+ fixed, seamonkey2.57esr? affected)

RESOLVED FIXED
seamonkey 2.75
Tracking Status
seamonkey2.49esr --- wontfix
seamonkey2.53 + fixed
seamonkey2.57esr ? affected

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

Details

(Whiteboard: SM2.53.3)

Attachments

(1 file)

Confirmation prompts for deleting things in the addressbook are pretty inconsistent and fairly generic. Sometimes the title is generic too.

This patch ports the following bug to SeaMonkey:

  • Bug 1319493 - Smart and context-sensitive Delete confirmation prompts in Address Book

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: Inconsistent and generic prompts for deletion in AB
Testing completed (on m-c, etc.): 2.53.3
Risk to taking this patch (and alternatives if risky): none
String changes made by this patch: 20 new strings, 9 strings removed

New strings are same as equivalent TB ones.

Attachment #9146851 - Flags: review?(frgrahl)
Attachment #9146851 - Flags: approval-comm-release?
Attachment #9146851 - Flags: approval-comm-esr60?
Comment on attachment 9146851 [details] [diff] [review]
Improve delete prompts

LGTM
Attachment #9146851 - Flags: review?(frgrahl)
Attachment #9146851 - Flags: review+
Attachment #9146851 - Flags: approval-comm-release?
Attachment #9146851 - Flags: approval-comm-release+
Attachment #9146851 - Flags: approval-comm-esr60?
Attachment #9146851 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/94a426143805
Improve address book deletion prompts. r=frg

Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey 2.75
Whiteboard: SM2.53.3
You need to log in before you can comment on or make changes to this bug.