Closed Bug 1636632 Opened 2 months ago Closed 2 months ago

WebRTC broken on Linux builds using --with-system-nspr/--with-system-nss

Categories

(Core :: WebRTC, defect)

76 Branch
Unspecified
Linux
defect

Tracking

()

RESOLVED INVALID

People

(Reporter: viktor_jaegerskuepper, Unassigned)

References

Details

There are two reports (for Arch Linux [1] and Debian unstable [2] respectively) that WebRTC does not work beginning with the current 76 release. I confirmed this on Arch Linux with a test site [3].

Both distributions use --with-system-nspr and --with-system-nss. Building without these options resolved the problem on Arch Linux.

[1] https://bugs.archlinux.org/task/66549
[2] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=960012
[3] https://janus.conf.meetecho.com/echotest.html

NSS 3.51 and 3.52 have an incompatible API for GCM params, meaning Firefox 76 is broken when compiled with NSS 3.52 unless you add the patch from bug 1624128 (which was backed out of 76).

From Comment 1 and the comments in Bug 1624128, this sounds like a distribution build issue and not something we can fix. Please reopen if I've missed something here.

Status: UNCONFIRMED → RESOLVED
Closed: 2 months ago
Resolution: --- → INVALID
Duplicate of this bug: 1636781
You need to log in before you can comment on or make changes to this bug.