Closed Bug 16376 Opened 20 years ago Closed 20 years ago

[RFE]Browser should remember scroll position of page

Categories

(SeaMonkey :: General, enhancement, P3)

enhancement

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 3891

People

(Reporter: dbaron, Assigned: don)

Details

I'm filing this against Browser-General and cc:ing radha and nisheeth.  I'd
guess it should belong to one of them.

DESCRIPTION:  Navigating with back/forward should preserve the user's position
on the page (and some point within, if the window is resized).  This happens in
IE4-5 and (quirkily) in NN4.x.  This is a major usability issue, I think.

One tricky issue with this bug is named anchors:  you want to preserve the
position *separately* for each named anchor.  (This is unlike form controls,
where I think you want to hold the data even when the named anchor changes.)

STEPS TO REPRODUCE:
 * Go to a page
 * Scroll down
 * Click a link, and let it load
 * hit "Back"

ACTUAL RESULTS:
 * You see the top of the previous page

EXPECTED RESULTS:
 * The previous page should be where it was when you clicked the link.

DOES NOT WORK CORRECTLY ON:
 * Linux, apprunner, 1999-10-13-12-M11
This should be tested carefully with frames, too...
OS: Linux → All
Hardware: PC → All
No such function is enabled as stands the MICROSOFT WINDOWS 98 build. I believe
users of all platforms would greatly appreciate this consideration.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 3891 ***
Status: RESOLVED → VERIFIED
QA Contact: leger → elig
Verified as duplicate.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.