If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

onFocus event occurrence on window object is not consistent.

VERIFIED DUPLICATE of bug 164686

Status

()

Core
Event Handling
VERIFIED DUPLICATE of bug 164686
15 years ago
15 years ago

People

(Reporter: Prashant Desale, Assigned: joki (gone))

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
onFocus event occurance on window object is not consistent. 

This one is regression. This was not happening on 2002-08-19-08-1.0

BUILDS IT STARTED OCCURING: 2002-08-20-08-1.0

STEPS TO REPRODUCE
1] Launch testcase I'm going to attach.
2] Click on this browser window [If it does not have focus by default]

EXPECTED RESULTS
We should see alert showing message "onfocus event triggered for new window"

ACTUAL RESULTS
Nothing happens.

####What do I mean by "onFocus event occurance on window object is not
consistent." ? ####

When you launch testcase, onFocus does NOT occur. If you play around with
browser window, giving focus to other window, then giving focus back to test
window, maximising, minimising, resizing the test window, at one point onFocus
Event will occur.
(Reporter)

Comment 1

15 years ago
Created attachment 96098 [details]
Testcase
(Reporter)

Comment 2

15 years ago
changing QA contact
QA Contact: rakeshmishra → desale
(Reporter)

Comment 3

15 years ago
If testcase I attached Works for you, then try testcase at 
http://bubblegum/browser/standards/events/JSevents_testcases/window_onfocus.html

Those are same testcases but show very unconsistant results. one or another fails.

Updated

15 years ago
Keywords: regression
(Reporter)

Comment 4

15 years ago
The testcase I attached is working fine, but same testcase from 
http://bubblegum/browser/standards/events/JSevents_testcases/window_onfocus.html

is not working. Dont know why.

Comment 5

15 years ago
The attached testcase and the testcase on bubblegum (comment 4) work for me.
However in playing with this I did manage to find a set of reproducible
circumstances where focus and blur events are both lost. Closing in favour of
the reproducible bug.

*** This bug has been marked as a duplicate of 164686 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Summary: onFocus event occurance on window object is not consistent. → onFocus event occurrence on window object is not consistent.
(Reporter)

Comment 6

15 years ago
Veriied Dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.