Closed Bug 1637847 Opened 2 years ago Closed 2 years ago

Active focus color for dark mode buttons in reader view popover is too light

Categories

(Toolkit :: Reader Mode, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1640417
Tracking Status
firefox78 --- fixed

People

(Reporter: yoasif, Unassigned)

References

Details

(Keywords: nightly-community)

Attachments

(1 file)

Steps to reproduce:

  1. Go to https://getpocket.com/explore/item/who-still-buys-wite-out-and-why
  2. Enable reader view
  3. enable dark view
  4. click any of increase/decrease font size, increase/decrease content width, and increase/decrease line height

What happens:

The color that on active click is too light/bright and looks out of place.

Expected result:

Something that feels a little less out of place, likely a bit darker.

Has STR: --- → yes
Depends on: 1550836

Hi akshitha! Any chance you might have some time to look at this?

Severity: -- → S4
Flags: needinfo?(akshithashetty84)

This issue existed before the redesign. I can reproduce it on Firefox 76 when I click on one of the font, width, or height buttons.

It looks like it's using #fff and #dadada in aboutReader.css. This has a contrast ratio of 1.39:1, which doesn't satisfy Web Content Accessibility Guidelines.

body.dark {
  --font-color: #fff;
}
.button:active,
.font-size-buttons > button:active,
.font-size-buttons > button.selected,
.content-width-buttons > button:active,
.content-width-buttons > button.selected,
.line-height-buttons > button:active,
.line-height-buttons > button.selected {
  background-color: #dadada;
}
Priority: -- → P3

I fixed this in bug 1640417.

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(akshithashetty84)
Resolution: --- → DUPLICATE
Duplicate of bug: 1640417
You need to log in before you can comment on or make changes to this bug.