Closed Bug 1638215 Opened 1 year ago Closed 8 months ago

Use HTTPS for CTRL+ENTER Fixup

Categories

(Firefox :: Address Bar, enhancement, P3)

76 Branch
enhancement
Points:
3

Tracking

()

RESOLVED FIXED
85 Branch
Iteration:
85.2 - Nov 30 - Dec 13
Tracking Status
firefox85 --- fixed

People

(Reporter: nivlpfxohtlfldutqw, Assigned: daisuke)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:76.0) Gecko/20100101 Firefox/76.0

Steps to reproduce:

Typed "firefox" in the address bar.
Pressed CTRL+ENTER.

Actual results:

http://www.firefox.com was entered.

Expected results:

I'm requesting an option to fixup with https.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Address Bar

May be a duplicate but didn't find it yet.

Blocks: 1628831
Severity: -- → S3
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: dupeme
Priority: -- → P3
Points: --- → 3
Assignee: nobody → daisuke
Status: NEW → ASSIGNED
Pushed by dakatsuka.birchill@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f59efe5a5ef8
Use https for canonization the URL. r=mak
Iteration: --- → 85.2 - Nov 30 - Dec 13
Flags: needinfo?(daisuke)
Blocks: 1680996
Pushed by dakatsuka.birchill@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a4ca06311d43
Use https for canonization the URL. r=mak
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 85 Branch

Folks, you just broke so many websites for people that use ctrl+enter to access sites that don't run a properly configured https and didn't intend to send anyone to https. Chrome and edge don't work this way. So end-users are seeing what is fairly described as "websites broken on firefox only". It's cool that you added an option "browser.fixup.alternate.protocol" , but you chose the wrong default.

This is an advanced feature, undiscoverable by non-technical users. The users of this feature are capable of using about:config to adapt it to their needs. We're moving towards https since it's the direction the Web is going.

You need to log in before you can comment on or make changes to this bug.