Closed Bug 1638557 Opened 4 months ago Closed 4 months ago

Perma TEST-UNEXPECTED-FAIL | browser/base/content/test/static/browser_all_files_referenced.js | there should be no unreferenced files - Got 1, expected 0 when Gecko 78 merges to beta on 2020-06-01

Categories

(WebExtensions :: Storage, defect)

defect

Tracking

(firefox-esr68 unaffected, firefox76 unaffected, firefox77 unaffected, firefox78+ verified)

VERIFIED FIXED
mozilla78
Tracking Status
firefox-esr68 --- unaffected
firefox76 --- unaffected
firefox77 --- unaffected
firefox78 + verified

People

(Reporter: NarcisB, Assigned: lina)

References

(Regression)

Details

Attachments

(1 file)

[Tracking Requested - why for this release]:

Central-as-beta simulation:
https://treeherder.mozilla.org/#/jobs?repo=try&group_state=expanded&selectedTaskRun=eCYRNEYlTEiDk0orh54UAg-0&resultStatus=testfailed%2Cbusted%2Cexception%2Crunnable&revision=74932c353811e45bebadcfac68e85f5ac6cd8295

Log link: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=302587862&repo=try&lineNumber=3307

Log snippet:
[task 2020-05-16T13:07:35.544Z] 13:07:35 INFO - indirectly whitelisted file: resource://services-sync/doctor.js used from resource://services-sync/bookmark_repair.js,resource://services-sync/stages/enginesync.js
[task 2020-05-16T13:07:35.544Z] 13:07:35 INFO - Buffered messages finished
[task 2020-05-16T13:07:35.547Z] 13:07:35 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/static/browser_all_files_referenced.js | there should be no unreferenced files - Got 1, expected 0
[task 2020-05-16T13:07:35.547Z] 13:07:35 INFO - Stack trace:
[task 2020-05-16T13:07:35.547Z] 13:07:35 INFO - chrome://mochikit/content/browser-test.js:test_is:1327
[task 2020-05-16T13:07:35.547Z] 13:07:35 INFO - chrome://mochitests/content/browser/browser/base/content/test/static/browser_all_files_referenced.js:checkAllTheFiles:957
[task 2020-05-16T13:07:35.548Z] 13:07:35 INFO - Not taking screenshot here: see the one that was previously logged
[task 2020-05-16T13:07:35.548Z] 13:07:35 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/static/browser_all_files_referenced.js | unreferenced file: resource://services-sync/bridged_engine.js -

Flags: needinfo?(lina)

Oh, right! I'll fix this by removing the MOZ_NEW_WEBEXT_STORAGE feature, since we have a pref now and intend to ship this in 78 for everyone.

Assignee: nobody → lina
Status: NEW → ASSIGNED
Component: General → Storage
Flags: needinfo?(lina)
Product: Firefox → WebExtensions

Now that we've landed all the pieces for Rust storage.sync, and
intend to ship it for everyone in 78, we don't need to hide it behind a
build flag. Setting the webextensions.storage.sync.kinto pref to
false toggles the new Rust backend at runtime.

Pushed by kcambridge@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d3c89deff8e5
Remove the `MOZ_NEW_WEBEXT_STORAGE` build flag. r=markh
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78

Narcis, could you please verify that the Beta sim is fixed now? This should also have fixed bug 1638300...

Thanks so much!

Flags: needinfo?(nbeleuzu)

Yes, this was fixed in today's beta simulations.

Status: RESOLVED → VERIFIED
Flags: needinfo?(nbeleuzu)
You need to log in before you can comment on or make changes to this bug.