Closed Bug 1638989 Opened 8 months ago Closed 3 months ago

Convert 'mach taskcluster-load-image' to run with Python 3

Categories

(Firefox Build System :: Task Configuration, task)

task

Tracking

(firefox84 fixed)

RESOLVED FIXED
84 Branch
Tracking Status
firefox84 --- fixed

People

(Reporter: KrisWright, Assigned: bhearsum)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

mach taskcluster-load-image still runs with python 2 [1]. We want to convert all mach commands to python 3.

To do this, any dependencies of the command may need to be converted as well as the command itself.

[1] https://searchfox.org/mozilla-central/rev/9193635dca8cfdcb68f114306194ffc860456044/taskcluster/mach_commands.py

This command is part of taskgraph, and converting that will allow this to be switched as well.

Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1638990

This command is still running with Python 2 so this bug should not be closed yet.

Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Assignee: nobody → bhearsum
Pushed by bhearsum@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/09731dfd5a31
run 'mach taskcluster-load-image' with python 3 r=releng-reviewers,aki DONTBUILD
Status: REOPENED → RESOLVED
Closed: 8 months ago3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 84 Branch
You need to log in before you can comment on or make changes to this bug.