Closed Bug 1639057 Opened 3 months ago Closed 3 months ago

Intermittent dom/events/test/test_bug426082.html | Test timed out.

Categories

(Core :: DOM: UI Events & Focus Handling, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla78
Tracking Status
firefox76 --- unaffected
firefox77 --- unaffected
firefox78 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: emilio)

References

(Regression)

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Filed by: cbrindusan [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=302819351&repo=mozilla-central
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/fCTwxN1-Q76PPFfa5Aychg/runs/0/artifacts/public/logs/live_backing.log


[task 2020-05-18T22:24:20.915Z] 22:24:20 INFO - TEST-START | dom/events/test/test_bug426082.html
[task 2020-05-18T22:24:43.302Z] 22:24:43 INFO - GECKO(2549) | [Child 2632: Socket Thread]: D/DataChannel Deleting DataChannelConnection 0x7f0688806000
[task 2020-05-18T22:29:41.976Z] 22:29:41 INFO - TEST-INFO | started process screentopng
[task 2020-05-18T22:29:42.290Z] 22:29:42 INFO - TEST-INFO | screentopng: exit 0
[task 2020-05-18T22:29:42.291Z] 22:29:42 INFO - Buffered messages logged at 22:24:21
[task 2020-05-18T22:29:42.292Z] 22:29:42 INFO - must wait for load
[task 2020-05-18T22:29:42.293Z] 22:29:42 INFO - TEST-PASS | dom/events/test/test_bug426082.html | Pressed focused buttons should look different from normal buttons. - got undefined and undefined
[task 2020-05-18T22:29:42.294Z] 22:29:42 INFO - TEST-PASS | dom/events/test/test_bug426082.html | Pressed focused buttons should look different from normal focused buttons. - got undefined and undefined
[task 2020-05-18T22:29:42.295Z] 22:29:42 INFO - Buffered messages finished
[task 2020-05-18T22:29:42.296Z] 22:29:42 INFO - TEST-UNEXPECTED-FAIL | dom/events/test/test_bug426082.html | Test timed out.

Set release status flags based on info from the regressing bug 1638127

Sure.

Assignee: nobody → emilio

Update: There have been 43 failures within the last 7 days on Linux 18.04 x64 shippable opt and Linux 18.04 x64 opt.

Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=303468363&repo=mozilla-central&lineNumber=5153

Flags: needinfo?(emilio)

I removed some outlines in gtk which causes some repaints not to show
up. However I think this test should be simplified a bit instead.

When this test landed in bug 426082, snapshots and such were the only
way to test this because it was a widget hack, effectively. Nowadays,
that "forward hover and active state from label to labeled element"
happens at the event state manager level, and thus we can test it much
more easily using simple selector-matching.

Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/59cfc02045fd
Simplify Bug 426082.html to not depend on paint events. r=mstange
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78
You need to log in before you can comment on or make changes to this bug.