Wrong layout on the Wall Street Journal pay web site

RESOLVED WORKSFORME

Status

()

P2
normal
RESOLVED WORKSFORME
17 years ago
16 years ago

People

(Reporter: mks, Assigned: kinmoz)

Tracking

({top100})

Trunk
Future
x86
Linux
top100
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(5 attachments)

(Reporter)

Description

17 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020710
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020710

Many (most) times in the main stories, the graph or image that goes with the
story seems to be in the wrong place.

What is even more interesting is the fact that it looks like layout tried to
place the graph/image in the right place because of the way the words wrapped. 
It then tried to place it into another location but still did not get it to the
correct spot when it rendered it.

See the above URL for one example.  Here is another but most any story will show
the same problem.

http://online.wsj.com/article/0,,SB1029932183323103595,00.html?mod=home_whats_news_us

I have seen layout render the pages correctly.  In fact, if you make a bookmark
on one of the pages with a problem and just load again and again from the
bookmark, it will, every once in a while, render the page correctly.

Using reload it will also render the page correctly sometimes (actually, more
often than with the bookmark mechanism).  Shift-reload rarely (if ever) renders
the page correctly.

Reproducible: Always

Steps to Reproduce:
1.Pick a main story at wsj.com
2.If it rendered wrong, reload it - it may render correctly this time
3.If it rendered correctly, reload it - it may render incorrectly this time.

Actual Results:  
The page had an image with the text from the page running into it and parts of
the text "wrapping" around an image that was not there.

Expected Results:  
Place the image into the correct location and not render text on top of the image.
(Reporter)

Comment 1

17 years ago
I have been unable to get some HTML that generates the problem.  When I save the
page from the site and then load it, the page looks correct.

Since I still can not reproduce it in a form I can send here, I am putting up
some images and a tarball of the HTML that produced it.
(Reporter)

Comment 2

17 years ago
Created attachment 96691 [details]
Image of the incorrect rendering of the page

An example page where things rendered incorrectly
(Reporter)

Comment 3

17 years ago
Created attachment 96692 [details]
The same page rendered correctly

This image is of that page rendered correctly (after I had saved the HTML
locally)
(Reporter)

Comment 4

17 years ago
Created attachment 96693 [details]
The HTML (tarball since it includes other parts) for this page

This tar-gz file contains the HTML and related files that generated this page.
(Reporter)

Comment 5

17 years ago
Note that the HTML/JavaScript acts a bit differently when run/loaded from the
local hard drive.  This may (or may not) impact the results.  It does change
what shows up on the left hand side.

Note also that this is not required to make the page render correctly as the
page will render correctly some of the time after doing a reload.
(Reporter)

Comment 6

17 years ago
BTW - The more I look at this, the more it looks like some race in the
icremental reflow.  The whole content is rendered and shows up but in the wrong
spot.  If you look at the HTML, the center part is just <P>..</P> tags and <img
src=... align=>
tags.

It looks like the page got the image size and started to lay it out in one
location and then later moved it and did not "remove" it from the old location.
 I am not sure yet, but it may only happen when there is more than one image
within the body of the story.  (Which would let the images "tractor" themselves
down the page)

The interesting thing is that if I reload or make a bookmark of the page and
click on the bookmark again, the results will either be correct or incorrect. 
There is no consistant behavior (that is, from click to click I can not predict
which will happen but given multiple clicks both the correct and incorrect
version will happen.)
(Reporter)

Comment 7

17 years ago
Created attachment 96698 [details]
A different story with bad layout (default browser setup/skin)
(Reporter)

Comment 8

17 years ago
Created attachment 96699 [details]
The same story after a reload that rendered correctly (default browser skin)
(Reporter)

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
-> Karnaze
Assignee: attinasi → karnaze
Keywords: top100
-> kin
Assignee: karnaze → kin
Priority: -- → P2
Target Milestone: --- → Future
(Reporter)

Comment 11

16 years ago
Well, I have not noticed the problem with Mozilla 1.4 - but then I am not on a
high-speed connection any more and that may have been related to the problem.

However, since I can not reproduce it in 1.4, I will now claim that it is working.

(Sorry I was not following this more closely but I have been a bit distracted)
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.