Closed Bug 163921 Opened 17 years ago Closed 16 years ago

mozilla+bugzilla trip over eachother to escape international/foreign characters (japanese, hebrew)

Categories

(Bugzilla :: Creating/Changing Bugs, defect)

2.17
x86
Windows 2000
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 135762

People

(Reporter: timeless, Assigned: myk)

References

()

Details

I entered
にほんご בּת.txt		にほんご בּת.txt.lnk		x:\desktop\にほんご בּת.txt
into a bug (bug 80579 comment 30)
when i read the bug, i got:
にほんご בּת.txt	
にほんご בּת.txt.lnk	
x:\desktop\にほんご בּת.txt

which is interesting, but well, it's not what i wanted.
if mozilla is going to encode characters using &#digits;, then bugzilla either
has to
1. not escape & for transmission
2. encode the character upon receipt, and decode it for transmission
3. not escape & if it precedes #

I'd file this as unconfirmed but I can't.

This doesn't appear to be bug 160096.

I know that other people have had problems with this, i think they went back to
some browser that didn't &# encode characters.
test using iso-8859-8-i
desktop.inidesktop.ini (2).lnkx:\program\winzip\desktop.ini
にほんご בּú.txtにほんご בּú.txt.lnkx:\desktop\にほんご בּú.txt
WinZipWinZip.lnkx:\programf\winzip
test using iso-2022-jp
desktop.inidesktop.ini (2).lnkx:\program\winzip\desktop.ini
$B$K$[$s$4(B בּת.txt$B$K$[$s$4(B בּת.txt.lnkx:\desktop\$B$K$[$s$4(B בּת.txt
WinZipWinZip.lnkx:\programf\winzip
test using utf-8
desktop.inidesktop.ini (2).lnkx:\program\winzip\desktop.ini
にほんご בּת.txtにほんご בּת.txt.lnkx:\desktop\にほんご בּת.txt
WinZipWinZip.lnkx:\programf\winzip
ok, this appears to be more of a mozilla bug in that it stabs me in the back
first and without any warning. i suspect the original bug was filed using
iso-8859-1.

*** This bug has been marked as a duplicate of 135762 ***
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
vrfy dupe
Status: RESOLVED → VERIFIED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.