Closed Bug 163930 Opened 18 years ago Closed 18 years ago

Very slow performance (for about 15 sec.) after long idle time

Categories

(SeaMonkey :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 76831

People

(Reporter: jb, Assigned: asa)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.0.0) Gecko/20020530
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.0.0) Gecko/20020530

I normally have the mail window and one browser window open all the time,
minimized to the taskbar when I don't need them. In some cases, when I haven't
used Mozilla for a while and then click on any of the task buttons in the
taskbar, the window takes very long to redraw (e.g. at least a second between
the drawing of the grey borders and the drawing of the white e-mail list), and
reactions to mouse clicks are very slow, too. After about 15 seconds or so,
performance returns to normal, which is quite fast on my Athlon XP 1800+. This
does not happen in all cases, but in about one thord, I guess. It never happens
when I minimize Mozilla and restore it shortly afterwards, only after longer
idle times.

Reproducible: Sometimes

Steps to Reproduce:
1. Open navigator and mail.
2. Minimize both to taskbar.
3. Wait a long time doing other stuff.
4. Click on any of the two tasks (or both) to restore them.

Actual Results:  
See above.

Expected Results:  
Restore and redraw at normal speed.
Oops ... "one thord" should read "one third" (of all cases).
*** Bug 163931 has been marked as a duplicate of this bug. ***
Well, I waited for about 2 minutes (grabbing my AntiVirus update), and on my
XP1800+ / 512 Mb, speed was "normal".

WFM.

1.1 RC from 18th august - WinXP.
It never occurs after 2 minutes - wait an hour or longer, then try to restore.

Joerg
Well, I *never* store in my taskbar an application for more than 10 minutes :-)

So, I cannot say for now ! :-/

Should be a WinXP bug, also :-/
I upgraded to Mozilla 1.1 (20020826) now, and the problem is still there.
Did you upgrade crushing older version ? Or making a clean install ?
I did a clean install of 1.1, but the behaviour is the same as with 1.0.
I just found out that the problem has probably nothing to do with the taskbar. I
left Mozilla open and *maximized* and found that after some time of not using
it, the performance is very slow for maybe 10 to 20 seconds (reaction to mouse
clicks and drawing of screen elements takes up to several seconds) until it
returns to normal.
Summary: Restoring from taskbar is sometimes extremely slow. → Very slow performance (for about 15 sec.) after long idle time

*** This bug has been marked as a duplicate of 76831 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.