Closed Bug 1639501 Opened 2 years ago Closed 10 months ago

[Ubuntu 20] Window controls are barely visible on light theme

Categories

(Firefox :: Theme, defect, P3)

Desktop
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1718846
Tracking Status
firefox76 --- affected
firefox77 --- affected
firefox78 --- affected
firefox79 --- affected
firefox80 --- affected

People

(Reporter: csasca, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Affected versions

  • Firefox 76.0.1
  • Firefox 77.0b8
  • Firefox 78.0a1

Affected platforms

  • Ubuntu 20 (x64)

Steps to reproduce

  1. Launch Firefox
  2. Access customize from the menu
  3. Unselect Title Bar (it is on by default)
  4. Activate light theme

Expected result

  • Window controls (minimize, maximize) are visible

Actual result

  • Window controls (minimize, maximize) are barely visible

Regression range

  • Will see for a regression.

Additional notes

  • The issue can be seen on the attachment.
Has Regression Range: --- → no
Has STR: --- → yes

S1 or S2 bugs need an assignee - could you find someone for this bug?

Flags: needinfo?(dao+bmo)
Blocks: gtktitlebar
Severity: S2 → S3
Flags: needinfo?(dao+bmo)
Priority: -- → P3
Attached file Theme inverted colors

While testing I did get across some themes inconsistencies.

It seems that if Standard system theme and dark theme in browser are applied, hovering over buttons (for example in themes dropdown) are inverted. The same goes for Dark system theme applied and White theme within browser. Will attach a screencast for this.

I don't think that this is a regression, but a inconvenience with ubuntu system themes. Tried tracking as back as 56.0a1 (2017-07-01) and there is no option to uncheck the title bar, so it doesn't seem that I can verify there. While on newer builds, it is reproducing constantly while title bar is unchecked.

Has Regression Range: no → ---
Duplicate of this bug: 1696949
See Also: → 1696953
See Also: → 1718846
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → DUPLICATE
See Also: 1718846
Duplicate of bug: 1718846
You need to log in before you can comment on or make changes to this bug.