History item, copied and pasted into Bookmarks Manager, does not become a usable bookmark

RESOLVED WORKSFORME

Status

--
minor
RESOLVED WORKSFORME
16 years ago
6 years ago

People

(Reporter: vlbrown, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2012 Fall Equinox])

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1b) Gecko/20020722
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1b) Gecko/20020722

I selected a URL in my history list, copied it and pasted it into the bookmaark
manager

In the History it looked like
[icon] PHP bugs: Search               http://bugs.php.net/search.php

When pasted, it looked like
[icon]                   ID:{http://bugs.php.net/search.php};NAME:{PHP Bugs:
Search};

That is, the name did not paste in AND the location field had extra information
(information that is unnecessary in a bookmark)


Reproducible: Always

Steps to Reproduce:
1.Go menu: History
2. Select a bookmark from the history list
3.Copy
4. Bookmarks menu: Manage Bookmarks
5. Select a locaton to Paste the bookmark
6. Paste

Actual Results:  
It pasted and looked _really weird :-)

Expected Results:  
It should have pasted the bookmark looking like a bookmark, with name and
location the way I saw them when viewing the history

Comment 1

16 years ago
I can't reproduce this bug.  When I try to paste the history item, I get the
following JavaScript error:

Error: [Exception... "Component returned failure code: 0x80004003
(NS_ERROR_INVALID_POINTER) [nsIRDFService.GetResource]"  nsresult: "0x80004003
(NS_ERROR_INVALID_POINTER)"  location: "JS frame ::
chrome://communicator/content/bookmarks/bookmarks.xml#bookmarks-tree.paste() ::
paste :: line 62"  data: no]
Source File:
chrome://communicator/content/bookmarks/bookmarks.xml#bookmarks-tree.paste()
Line: 62


Vicki, can you still reproduce this bug on a more recent build?

Comment 2

16 years ago
Confirmed using FizzillaMach/2003021203. Copying <http://www.mozilla.org/> from
History and pasting it into the Bookmarks Manager resulted in a bookmark with no
Name and a Location value of "ID:{http://www.mozilla.org/};NAME:{mozilla.org};".
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Unexpected results when copy/pasting history item to bookmarks → History item, copied and pasted into Bookmarks Manager, does not become a usable bookmark
Product: Browser → Seamonkey

Updated

13 years ago
Blocks: 103392

Updated

13 years ago
Blocks: 112531
No longer blocks: 103392
Assignee: bugs → nobody
QA Contact: claudius → bookmarks

Comment 3

11 years ago
Tony do you see this?
(In reply to comment #3)
> Tony do you see this?
> 

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008052601 SeaMonkey/2.0a1pre

Trying the "Steps to Reproduce" in comment #0 - At step 6, nothing happens.

What works instead, is:
6. New -> Bookmark
7. Place the cursor in URL field
8. Paste (or Ctrl+V)
9. (required) Type something in the Name field
10. (optional) Type something in the Description field
11. Click OK.

Then the bookmark gets created.

Comment 5

6 years ago
WFM here, on Paste bookmark correctly creates in selected folder, closing
User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 SeaMonkey/2.15a1
Build identifier: 20120921003032
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Whiteboard: [2012 Fall Equinox]
You need to log in before you can comment on or make changes to this bug.