Closed Bug 1639616 Opened 1 year ago Closed 1 year ago

[Protections Dashboard 1.5] Monitor card cache has stopped working

Categories

(Firefox :: Protections UI, defect, P1)

78 Branch
defect

Tracking

()

RESOLVED FIXED
Firefox 78
Tracking Status
firefox-esr68 --- unaffected
firefox76 --- unaffected
firefox77 --- wontfix
firefox78 --- fixed

People

(Reporter: ewright, Assigned: ewright)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

The Monitor card now fully updates with each refresh, we should look into why this changed, and either fix the cache or remove related code.

Assignee: nobody → ewright
Status: NEW → ASSIGNED
Severity: -- → S3
Keywords: regression
Regressed by: 1614743

Neil, We've lost our ability to cache because in browser/actors/AboutProtectionsParent.jsm the AboutProtectionsParent is rerunning the constructor on each page refresh. Is this part of the JSWindowActor design?

Flags: needinfo?(enndeakin)

Yes, so it looks like monitorResponse should just be a global instead of a member. Is there an easy way to test the issue being caused here? Or write an automated test?

Flags: needinfo?(enndeakin) → needinfo?(ewright)

Set release status flags based on info from the regressing bug 1614743

(In reply to Neil Deakin from comment #2)

Yes, so it looks like monitorResponse should just be a global instead of a member. Is there an easy way to test the issue being caused here? Or write an automated test?

To test manually:
go to about:protections
log into your Firefox account, and sign up for monitor
refresh the page - you should see your monitor data.
open browser dev tools and set a debugger on browser/actors/AboutProtectionsParent.jsm line 78 (if (this.monitorResponse && this.monitorResponse.timestamp) {)
refresh the page again, and this.monitorResponse should be an object, but instead it is null

We can write an automated test for this fairly easily - should have done it before. I can do that.

Flags: needinfo?(ewright)

Wontfix for 77 as we shipped our last beta and this is a S3.

Pushed by ewright@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c7363797d74f
Turn Monitor cache back on. r=prathiksha
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 78
You need to log in before you can comment on or make changes to this bug.