Closed Bug 1639756 Opened 4 months ago Closed 4 months ago

copy/paste error in disabled button UA rules

Categories

(Core :: CSS Parsing and Computation, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla78
Tracking Status
firefox78 --- fixed

People

(Reporter: heycam, Assigned: emilio)

References

Details

Attachments

(6 files)

Flags: needinfo?(emilio)

This will allow us to clean them up.

Assignee: nobody → emilio
Status: NEW → ASSIGNED

I also removed some unneeded specific selectors for ::placeholder /
::-moz-text-control-editing-root / etc. We only query them for textarea
/ input elements, so it is more of a pesimization than an optimization.

Depends on D76262

Flags: needinfo?(emilio)

There's some lists code that I could technically clean up a bit more, but I
erred in the side of making the selectors as fast as possible with our current
infrastructure.

For example, this selector list:

:is(ul, ol, dir, menu, dl) ul,
:is(ul, ol, dir, menu, dl) ol,
:is(ul, ol, dir, menu, dl) dir,
:is(ul, ol, dir, menu, dl) menu,
:is(ul, ol, dir, menu, dl) dl

Could be reduced to:

:is(ul, ol, dir, menu, dl) :is(ul, ol, dir, menu, dl)

But that means that for dl elements we'll selector-match all the selectors
inside the :is() instead of just dl. Maybe it doesn't matter compared with
the work of going up all the parent chain, but I erred in the side of caution
for most of these.

Depends on D76264

This one I went all-in with :is(). Because even if we have to do some more
selector-matching for each element, we need to check the more expensive
selectors and the combinators less often, so I don't think we end up worse than
before, and the difference is massive.

Depends on D76265

Depends on: 1639852
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/67dcbffe8b5b
Enable :is() and :where() in UA sheets. r=jwatt
https://hg.mozilla.org/integration/autoland/rev/c161d7a53845
Clean-up forms.css by using :is(). r=jwatt
https://hg.mozilla.org/integration/autoland/rev/b8e3a5d241c9
Cleanup ua.css by using :is(). r=jwatt
https://hg.mozilla.org/integration/autoland/rev/ff407bdf357e
Cleanup html.css using :is(). r=jwatt
https://hg.mozilla.org/integration/autoland/rev/9d8f9a2cd37f
Clean up quirks.css using :is(). r=jwatt
Regressions: 1643279
You need to log in before you can comment on or make changes to this bug.