Trying to resize a tree-column of a tree inside a box with overflow:auto freezes the mouse

RESOLVED WORKSFORME

Status

()

Core
XUL
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: ajbu, Assigned: janv)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.09 KB, application/vnd.mozilla.xul+xml
Details
(Reporter)

Description

16 years ago
Tested on build WinXP, build 2002082109 and Linux RH7.3/CVS
This resizing works with 1.1 alpha, but stopped working in 1.1b, so it broke 
sometime in June / July. 
When placing a tree inside a box(vbox/hbox) with style="overflow:auto" and 
using a tree-splitter between columns, the XUL Window freezes when trying to 
resize a column.
Expected results: resizing a column resizes the column.
Actual results: window freezes, no more mouse input is possible.
Note that when using a splitter without class=tree-splitter, it works, but 
using:
<splitter style="max-width: 0px"/>
also breaks the resize function.
Problem seems to be caused by the combination of overflow:auto and max-width 0.

Test case follows.
(Reporter)

Comment 1

16 years ago
Created attachment 96303 [details]
Testcase

when resizing with the splitter between First Name and Last Name mouse stops
responding inside window. (mouse still moves, but no change in cursor bitmap
and it is impossible to click)
(Assignee)

Comment 2

15 years ago
I can reproduce it, reassigning for now.
Assignee: hewitt → varga

Comment 3

15 years ago
This bug is a duplicate of #213103
(Assignee)

Comment 4

15 years ago
WFM
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: shrir → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.