Closed Bug 1640289 Opened 4 months ago Closed 4 months ago

Perma browser_UsageTelemetry_urlbar.js | unexpected counts should be zero for FX_URLBAR_SELECTED_RESULT_INDEX at index 1 - 1 == 0 when Gecko 78 merges to Beta on 2020-06-01

Categories

(Firefox :: Address Bar, defect, P1)

defect
Points:
2

Tracking

()

VERIFIED FIXED
Firefox 78
Iteration:
78.2 - May 18 - May 31
Tracking Status
firefox-esr68 --- unaffected
firefox76 --- unaffected
firefox77 --- unaffected
firefox78 + verified

People

(Reporter: aryx, Assigned: adw)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

central-as-beta simulation: https://treeherder.mozilla.org/#/jobs?repo=try&group_state=expanded&selectedTaskRun=DdiAK-jSTsifIfoTaVGj0g-0&resultStatus=testfailed%2Cbusted%2Cexception%2Cretry%2Cusercancel%2Crunnable&revision=0799f0ae22aa66449b8845124b82a77f8ef2061f&searchStr=browser-chrome

Log: https://treeherder.mozilla.org/logviewer.html#?job_id=303382464&repo=try

17:07:40 INFO - TEST-UNEXPECTED-FAIL | browser/modules/test/browser/browser_UsageTelemetry_urlbar.js | unexpected counts should be zero for FX_URLBAR_SELECTED_RESULT_INDEX at index 1 - 1 == 0 - JS frame :: resource://testing-common/TelemetryTestUtils.jsm :: assertHistogram :: line 297
4290 17:07:40 INFO - TEST-UNEXPECTED-FAIL | browser/modules/test/browser/browser_UsageTelemetry_urlbar.js | expected counts should match for FX_URLBAR_SELECTED_RESULT_INDEX at index 2 - 0 == 1 - JS frame :: resource://testing-common/TelemetryTestUtils.jsm :: assertHistogram :: line 291
4301 17:07:40 INFO - TEST-UNEXPECTED-FAIL | browser/modules/test/browser/browser_UsageTelemetry_urlbar.js | unexpected counts should be zero for FX_URLBAR_SELECTED_RESULT_INDEX_BY_TYPE_2 at index 1 - 1 == 0 - JS frame :: resource://testing-common/TelemetryTestUtils.jsm :: assertKeyedHistogramValue :: line 360
4306 17:07:40 INFO - TEST-UNEXPECTED-FAIL | browser/modules/test/browser/browser_UsageTelemetry_urlbar.js | expected counts should match for FX_URLBAR_SELECTED_RESULT_INDEX_BY_TYPE_2 at index 2 - 0 == 1 - JS frame :: resource://testing-common/TelemetryTestUtils.jsm :: assertKeyedHistogramValue :: line 354

Flags: needinfo?(adw)
Summary: Perma Late Beta browser_UsageTelemetry_urlbar.js | unexpected counts should be zero for FX_URLBAR_SELECTED_RESULT_INDEX at index 1 - 1 == 0 when Gecko 78 merges to Late Beta on 2020-06-12 → Perma browser_UsageTelemetry_urlbar.js | unexpected counts should be zero for FX_URLBAR_SELECTED_RESULT_INDEX at index 1 - 1 == 0 when Gecko 78 merges to Beta on 2020-06-01

Hmm, this didn't happen on the simulation I ran in bug 1398416 comment 47. Maybe it's intermittent? Shouldn't be though... I'll take a look.

Assignee: nobody → adw
Severity: -- → S3
Status: NEW → ASSIGNED
Iteration: --- → 78.2 - May 18 - May 31
Points: --- → 2
Flags: needinfo?(adw)
Priority: -- → P1

I think it's because the private search result is shown in Nightly but not otherwise. The test is failing because it expects the private search result to be at index 1 and the form history result to be at index 2, but the form history is actually at index 1. My simulation didn't catch it because it was still a Nightly build, so it still had the private search result. The test just needs to get the right index. There's another part of the test that clicks a remote suggestion, but it's not affected because the search happens to match a couple of history results, so the private search result isn't shown even on Nightly.

The private search result is shown in Nightly but not otherwise. The test is
failing because it expects the private search result to be at index 1 and the
form history result to be at index 2, but the form history is actually at index

  1. The test just needs to get the right index. There's another part of the test
    that clicks a remote suggestion, but it's not affected because the search
    happens to match a couple of history results, so the private search result isn't
    shown even on Nightly.

Looks like it fixes it, thanks Sebastian.

Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e70cfe6e8da9
Fix failure on late beta and release by getting the correct index of the form history result. r=mak
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 78
You need to log in before you can comment on or make changes to this bug.