Closed Bug 1640580 Opened 1 year ago Closed 1 year ago

mach try auto doesn't schedule web platform tests

Categories

(Firefox Build System :: Try, defect, P1)

defect

Tracking

(firefox78 fixed)

RESOLVED FIXED
mozilla78
Tracking Status
firefox78 --- fixed

People

(Reporter: sg, Assigned: ahal)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

I recently did several mach try auto pushes with local changes to dom/indexedDB/*.cpp files, e.g. https://treeherder.mozilla.org/#/jobs?repo=try&revision=210a4bf8a8856ecde6ef0167f33679db93b87ec0&selectedTaskRun=aIdpalNyRgamfIvS7xksAA-0

This seems to run the relevant mochitest and xpchshell-test test suites, but it failed to select the /IndexedDB/ web platform tests.

Thanks for filing!

I see the ML selected testing/web-platform/tests/indexedDB with 94% confidence. In fact it selected other WPT manifests with 99% confidence, yet no tasks were run. So this is a problem with the taskgraph code rather than the ML algorithm.

I'd guess it's a regression either from bug 1608837 or a change to bugbug. Marco, did you end up landing that change where you were returning the full path from bugbug rather than the ids? Looks like the group names are mismatching.

Blocks: 1608837
Severity: -- → S3
Flags: needinfo?(mcastelluccio)
Priority: -- → P1
Regressed by: 1608837
Summary: mach try auto misses IndexedDB web platform tests → mach try auto doesn't schedule web platform tests

Oh, looks like you did (duh, I was looking right at the line that gave me the answer). Ok, in that case not a regression from bug 1608837. In fact we have bug 1638429 filed to handle this change already, but we never ended up coordinating on the landing. I'll just dupe that here.

No longer regressed by: 1608837
Duplicate of this bug: 1638429
Assignee: nobody → ahal
Status: NEW → ASSIGNED
Flags: needinfo?(mcastelluccio)

I tested the above patch out by rebasing Simon's patch on top of my fix:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=f489ebac861a22793d95b000dea4048846b4688c

I didn't let the tasks finish running to save resources, but we are clearly scheduling wpt tasks again (whereas on the push in comment 0 we weren't).

Pushed by ahalberstadt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dc5a758cb608
[taskgraph.util.bugbug] Translate WPT paths from relative source directory to WPT ids, r=marco
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78
Blocks: 1668753
You need to log in before you can comment on or make changes to this bug.