Closed Bug 1641510 Opened 8 months ago Closed 8 months ago

Webrender "blocked by env: Monitor refresh rate too high"

Categories

(Core :: Graphics: WebRender, defect, P1)

77 Branch
x86_64
Windows 10
defect

Tracking

()

VERIFIED FIXED
mozilla78
Tracking Status
firefox-esr68 --- unaffected
firefox76 --- unaffected
firefox77 + verified
firefox78 --- verified

People

(Reporter: come, Assigned: aosmond)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached file about_support.js

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:77.0) Gecko/20100101 Firefox/77.0

Steps to reproduce:

I use two 24" 4K screens with a nVidia GeForce 1030 GT.

Before Firefox 77 WebRender was working well and is fast. With Firefox 77 WebRender is incorrectly blacklisted and Direct3D 11 is used and Firefox is sluggish.

Actual results:

WebRender is blacklisted since Firefox 77 for obscure reason : "blocked by env: Monitor refresh rate too high".

The monitors are both 60 Hz.

Expected results:

WebRender should be enable by default in this setup, as it has been since Firefox 68.

"message": "Monitor refresh rate too high"

"DisplayCount": 2,
"Display0": "3840x2160@60Hz ",
"Display1": "3840x2160@60Hz "

Flags: needinfo?(aosmond)
Keywords: regression
OS: Unspecified → Windows 10
Regressed by: 1638011
Hardware: Unspecified → x86_64

Oh my. I landed >=, when I very much intended >. I probably changed that for testing :|.

Assignee: nobody → aosmond
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(aosmond)
Severity: -- → S1
Has Regression Range: --- → yes
Has STR: --- → yes
Root Cause: --- → Coding: Logical Error
Priority: -- → P1
Target Milestone: --- → mozilla77

This regression only affects non-Nightly as Nightly must test WebRender even with high refresh rates.
The patch was uplifted 2020-05-24. (Latest) Beta Telemetry from 2020-05-25 doesn't show the decline yet: https://sql.telemetry.mozilla.org/public/dashboards/Zo3A3uEtmUIEyhA5hRpSHPFtNXJ0BzPxtTKPUxSJ (gfxCompositor beta)

Target Milestone: mozilla77 → ---
Pushed by aosmond@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/025cc24df2dd
Ensure we allow WebRender on beta/release for 60 Hz monitors. r=jrmuizel

Comment on attachment 9152369 [details]
Bug 1641510 - Ensure we allow WebRender on beta/release for 60 Hz monitors.

Beta/Release Uplift Approval Request

  • User impact if declined: Users with 60 Hz monitors (82% of pop) won't get WebRender.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: On Windows -- with a 60 Hz monitor, ensure you still get WebRender, with > 60 Hz monitor, ensure you don't get WebRender.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The change is trivially understood. We added more tests for the edge cases we broke before.
  • String changes made/needed:
Attachment #9152369 - Flags: approval-mozilla-release?
Flags: qe-verify+

Comment on attachment 9152369 [details]
Bug 1641510 - Ensure we allow WebRender on beta/release for 60 Hz monitors.

Driver for RC3

Attachment #9152369 - Flags: approval-mozilla-release? → approval-mozilla-release+
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78
QA Whiteboard: [qa-triaged]

Reproduced the initial issue using a monitor with 60hz and a dual monitor setup (60hz max | 240hz max) and Firefox 77.0 rc1, verified that using a Firefox 77.0 rc3 webrender is not blocked anymore by Monitor refresh rate too high when using a single monitor with 60hz or two with 60hz, but it is blocked if using 144hz or higher in a single setup or in a dual setup with 60hz | 144hz (or higher).
Leaving the bug opened to verify on 78 beta (since nightly is not affected by this) once it launches.

Also verified on Firefox 78.0b1 with the same setup as above.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.