Closed Bug 1641806 Opened 1 month ago Closed 1 month ago

configure does not check for libclang 5

Categories

(Firefox Build System :: General, defect, P3)

All
Linux
defect

Tracking

(firefox79 fixed)

RESOLVED FIXED
mozilla79
Tracking Status
firefox79 --- fixed

People

(Reporter: msirringhaus, Assigned: mhentges)

References

(Regression)

Details

Attachments

(1 file)

With bug 1579189, libclang >= 5.0 is now the minimal version, but build/moz.configure/bindgen.configure still checks for >= 4.0
( see https://searchfox.org/mozilla-central/source/build/moz.configure/bindgen.configure#225 ), leading to a broken build at some point due to the unrecognized build-flag -std=gnu++17.

Configure should fail right at the beginning.

Regressed by: 1579189
Severity: -- → S3
Keywords: in-triage
Priority: -- → P3
Assignee: nobody → mhentges
Keywords: in-triage

clang_getAddressSpace was found as a clang 5.0+ API by comparing the "tools/libclang/libclang.exports" files in the clang source code.
"clang_getAddressSpace" exists for 5.0.0 and 10.0.0, but not for 4.0.1.

Pushed by mhentges@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bddb6d72204c
configure should look for libclang >= 5.0 r=rstewart
Status: UNCONFIRMED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla79
You need to log in before you can comment on or make changes to this bug.