Closed Bug 1642184 Opened 1 year ago Closed 1 year ago

fails to build: file not found: icudt67b.dat for config/external/icu/data/icudata_gas.S

Categories

(Core :: Internationalization, defect)

Other
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1264836

People

(Reporter: dan, Unassigned)

References

(Regression)

Details

Our CI says that there has been a change between commits c09d6c731f7c182ee44393d370a43a39c369c48d (May 29) and d9d492eda787a6eda66016e6f8398ee759f7bc25 (May 30) (using https://github.com/mozilla/gecko-dev) that breaks builds on s390x and I assume on any big endian arch. This is build with bundled ICU.

gmake[4]: Entering directory '/home/jenkins/workspace/Firefox-default/label/s390x/firefox/obj-s390x-ibm-linux-gnu/config/external/icu/data'
mkdir -p '.deps/'
config/external/icu/data/icudata_gas.o
/usr/bin/gcc -std=gnu99 -o icudata_gas.o -DNDEBUG=1 -DTRIMMED=1 -fPIC -Wa,--noexecstack -include /home/jenkins/workspace/Firefox-default/label/s390x/firefox/obj-s390x-ibm-linux-gnu/mozilla-config.h -DMOZILLA_CLIENT -g -I/home/jenkins/workspace/Firefox-default/label/s390x/firefox/config/external/icu/data -I/home/jenkins/workspace/Firefox-default/label/s390x/firefox/config/external/icu/data/ '-DICU_DATA_FILE="icudt67b.dat"' -DICU_DATA_SYMBOL=icudt67_dat  -c /home/jenkins/workspace/Firefox-default/label/s390x/firefox/config/external/icu/data/icudata_gas.S
/home/jenkins/workspace/Firefox-default/label/s390x/firefox/config/external/icu/data/icudata_gas.S: Assembler messages:
/home/jenkins/workspace/Firefox-default/label/s390x/firefox/config/external/icu/data/icudata_gas.S:17: Error: file not found: icudt67b.dat
gmake[4]: *** [/home/jenkins/workspace/Firefox-default/label/s390x/firefox/config/rules.mk:743: icudata_gas.o] Error 1
gmake[4]: Leaving directory '/home/jenkins/workspace/Firefox-default/label/s390x/firefox/obj-s390x-ibm-linux-gnu/config/external/icu/data'
gmake[3]: *** [/home/jenkins/workspace/Firefox-default/label/s390x/firefox/config/recurse.mk:74: config/external/icu/data/target-objects] Error 2

More details will follow.

Component: General → Internationalization
Regressed by: 1635764

The change was done on purpose. If you weren't building with either system ICU or manually patching to get the right data file you'd produce yourself, you weren't getting something that works.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 264836
Duplicate of bug: 1264836

Makes sense, thanks.

You need to log in before you can comment on or make changes to this bug.