Closed Bug 1643192 Opened 4 months ago Closed 3 months ago

`mach wpt --manifest-download` fails on git

Categories

(Firefox Build System :: General, defect)

x86_64
Windows 10
defect

Tracking

(firefox79 fixed)

RESOLVED FIXED
mozilla79
Tracking Status
firefox79 --- fixed

People

(Reporter: saschanaz, Assigned: saschanaz)

References

(Regression)

Details

Attachments

(1 file)

$ ./mach wpt --manifest-download
Error running mach:

    ['wpt', '--manifest-download']

The error occurred in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.
You can invoke |./mach busted| to check if this issue is already on file. If it
isn't, please use |./mach busted file wpt| to report it. If |./mach busted| is
misbehaving, you can also inspect the dependencies of bug 1543241.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

WindowsError: [Error 87] The parameter is incorrect

  File "c:\Users\Kagami\Documents\GitHub\gecko-dev\testing/web-platform/mach_commands.py", line 377, in run_wpt
    return self.run_web_platform_tests(**params)
  File "c:\Users\Kagami\Documents\GitHub\gecko-dev\testing/web-platform/mach_commands.py", line 369, in run_web_platform_tests
    return wpt_runner.run(logger, **params)
  File "c:\Users\Kagami\Documents\GitHub\gecko-dev\testing/web-platform\mach_commands_base.py", line 33, in run
    self.update_manifest(logger)
  File "c:\Users\Kagami\Documents\GitHub\gecko-dev\testing/web-platform\mach_commands_base.py", line 58, in update_manifest
    **kwargs)
  File "c:\Users\Kagami\Documents\GitHub\gecko-dev\testing/web-platform\manifestupdate.py", line 115, in run
    force=force_download)
  File "c:\Users\Kagami\Documents\GitHub\gecko-dev\testing/web-platform\manifestdownload.py", line 191, in download_from_taskcluster
    force)
  File "c:\Users\Kagami\Documents\GitHub\gecko-dev\testing/web-platform\manifestdownload.py", line 144, in download_manifest
    commits = commits_func()
  File "c:\Users\Kagami\Documents\GitHub\gecko-dev\testing/web-platform\manifestdownload.py", line 189, in <lambda>
    lambda: get_commits(logger, repo_root),
  File "c:\Users\Kagami\Documents\GitHub\gecko-dev\testing/web-platform\manifestdownload.py", line 37, in get_commits
    base_rev = repo.base_ref
  File "c:\Users\Kagami\Documents\GitHub\gecko-dev\python/mozversioncontrol\mozversioncontrol\__init__.py", line 467, in base_ref
    return self._run('merge-base', 'HEAD', *refs).strip()
  File "c:\Users\Kagami\Documents\GitHub\gecko-dev\python/mozversioncontrol\mozversioncontrol\__init__.py", line 115, in _run
    universal_newlines=True)
  File "c:\mozilla-build\python\lib\subprocess.py", line 216, in check_output
    process = Popen(stdout=PIPE, *popenargs, **kwargs)
  File "c:\mozilla-build\python\lib\subprocess.py", line 394, in __init__
    errread, errwrite)
  File "c:\mozilla-build\python\lib\subprocess.py", line 644, in _execute_child
    startupinfo)

Looks like it's similar with Bug 1543872.

OS: All → Windows 10
Hardware: All → x86_64
Regressed by: 1631348

Use of .base_ref currently fails on git environment on Windows. It shouldn't be used or it at least should be fixed.

See Also: → 1633662
See Also: → 1543872

Since there are still needs for .base_ref(), this uses git log way to get base commit.

Assignee: nobody → krosylight
Status: NEW → ASSIGNED
Pushed by krosylight@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/71d7d5c52c77
Use git log to get base ref r=glandium
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla79
You need to log in before you can comment on or make changes to this bug.