Closed Bug 1643270 Opened 1 month ago Closed 1 month ago

Arrays/Objects in the Response panel are not expandable

Categories

(DevTools :: Netmonitor, defect, P2)

defect

Tracking

(firefox-esr68 unaffected, firefox77 unaffected, firefox78 fixed, firefox79 fixed)

RESOLVED FIXED
Firefox 79
Tracking Status
firefox-esr68 --- unaffected
firefox77 --- unaffected
firefox78 --- fixed
firefox79 --- fixed

People

(Reporter: Honza, Assigned: bomsy)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(2 files)

STR:

  1. Load http://janodvarko.cz/xhr-spy/
  2. Open DevTools and select the Network panel
  3. Click POST JSON With Array button
  4. Select the request and open the Response panel
  5. Try to collapse the arr array it doesn't work => BUG

ER: Expanding/collapsing works

Honza

Summary: Arrays in the Response panel are not expandlable → Arrays in the Response panel are not expandable
Attached image image.png

Also, it might be related, the tree node indentation seems to be broken.

@Bomsy, can you reproduce this one or it's just on my machine?

I see it in m-c only (not in Nightly), so could this be something recent?

Honza

Flags: needinfo?(hmanilla)

Yes I see it!
Looks like a regression, likely Bug 1639387

Flags: needinfo?(hmanilla)
Regressed by: 1639387
  • Fixes Bug 1643270 with unexpandale nodes
  • Fixes Bug 1643296 so clicking any part of the method cllapses the node
Assignee: nobody → hmanilla
Status: NEW → ASSIGNED

Adding objects, as reported on matrix.

Summary: Arrays in the Response panel are not expandable → Arrays/Objects in the Response panel are not expandable
Pushed by hmanilla@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/051d7f284389
Isolate headers panel treeview css changes r=Honza
Pushed by hmanilla@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/535035537a93
Isolate headers panel treeview css changes r=Honza
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 79

Comment on attachment 9154143 [details]
Bug 1643270 - Isolate headers panel treeview css changes r=honza

Beta/Release Uplift Approval Request

  • User impact if declined: Impacts developers, Arrays in the Response panel are not expandable
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Only affects developers , Small patch , Only few css changes
  • String changes made/needed:
Flags: needinfo?(hmanilla)
Attachment #9154143 - Flags: approval-mozilla-beta?

Comment on attachment 9154143 [details]
Bug 1643270 - Isolate headers panel treeview css changes r=honza

netmonitor regression fix, approved for 78.0b5

Attachment #9154143 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.