Closed Bug 1643645 Opened 2 years ago Closed 2 years ago

[Wayland] Firefox crashes on middle mouse button click

Categories

(Core :: Widget: Gtk, defect, P3)

77 Branch
x86_64
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1640651
Tracking Status
firefox77 --- wontfix

People

(Reporter: grmat, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash)

Attachments

(1 file)

26.68 KB, text/plain
Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:77.0) Gecko/20100101 Firefox/77.0

Steps to reproduce:

Middle-click to toggle autoscroll.

I was able to reproduce it a few times but it doesn't happen every time.

I'm not sure if disabling autoscroll prevents the crash. I've not been able to make a connection between primary clipboard (selection/paste with middle mouse) state and the crash.

Actual results:

Firefox crashed.

Expected results:

Autoscroll should've been enabled.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Widget: Gtk
Product: Firefox → Core

Please open about:crashes to check whether there are unsubmitted crash reports and submit them. (If wanted, automatic submission can be enabled on about:preferences#privacy-reports.) Then open about:support, click on "Copy text to clipboard" and paste it here. It contains graphics information, desktop environment and possibly some crash reports. Thanks!
There are bug 1638084 and bug 1640651 which I encountered with >= 78.

Keywords: crash
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Blocks: wayland
Priority: -- → P3
Attached file about:support

I've submitted crash reports already before filing the bug.

I've also found bug 1634723 and commented there before, it might be a duplicate of bug 1640651.

Try to change widget.wayland_vsync.enabled value to "false" in about:config.

(In reply to grmat from comment #3)

Note that I've disabled Firefox' Wayland and use it on xwayland for now. It already got unusable for me in 77 (see bug 1642920) without the crashes.

I might try without widget.wayland_vsync.enabled later.

So I haven't experienced a crash since disabling widget.wayland_vsync. It was stupid of me to keep this setting on, as it doesn't even work in the first place.

See Also: → 1640651
See Also: → 1638084

(In reply to grmat from comment #7)

So I haven't experienced a crash since disabling widget.wayland_vsync. It was stupid of me to keep this setting on, as it doesn't even work in the first place.

Hmm? widget.wayland_vsync.enabled works, but the regressions from bug 1623974 hit harder/more often when vsync is enabled.

I see you have a bug for an observed "fps cap" of sorts. Let's take the discussion for that over there.

I guess it's dupe of Bug 1640651.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1640651
You need to log in before you can comment on or make changes to this bug.