Closed Bug 1643708 Opened 8 months ago Closed 7 months ago

Intermittent /focus/focus-restoration-in-different-site-iframes.html | Check result - assert_equals: Check log expected "outerlog:log:bodyfocus,inputfocus,inputblur,bodyblur,bodyfocus,inputfocus," but got "outerlog:log:bodyfocus,inputfocus,inputblur,bodyb

Categories

(Testing :: web-platform-tests, defect, P5)

defect

Tracking

(firefox79 fixed)

RESOLVED FIXED
mozilla79
Tracking Status
firefox79 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: hsivonen)

References

(Regression)

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Filed by: nbeleuzu [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=305219098&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/FXaWEr-wQBW4gxCR9_a20A/runs/0/artifacts/public/logs/live_backing.log


[task 2020-06-05T13:37:55.079Z] 13:37:55 INFO - TEST-START | /fullscreen/idlharness.window.html
[task 2020-06-05T13:37:55.089Z] 13:37:55 INFO - Closing window 48
[task 2020-06-05T13:37:55.412Z] 13:37:55 INFO -
[task 2020-06-05T13:37:55.413Z] 13:37:55 INFO - TEST-UNEXPECTED-FAIL | /focus/focus-restoration-in-different-site-iframes.html | Check result - assert_equals: Check log expected "outerlog:log:bodyfocus,inputfocus,inputblur,bodyblur,bodyfocus,inputfocus," but got "outerlog:log:bodyfocus,inputfocus,inputblur,bodyblur,"
[task 2020-06-05T13:37:55.413Z] 13:37:55 INFO - window.onmessage/<@http://web-platform.test:8000/focus/focus-restoration-in-different-site-iframes.html:10:22
[task 2020-06-05T13:37:55.413Z] 13:37:55 INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1977:25
[task 2020-06-05T13:37:55.413Z] 13:37:55 INFO - test@http://web-platform.test:8000/resources/testharness.js:535:30
[task 2020-06-05T13:37:55.413Z] 13:37:55 INFO - window.onmessage@http://web-platform.test:8000/focus/focus-restoration-in-different-site-iframes.html:9:9
[task 2020-06-05T13:37:55.413Z] 13:37:55 INFO - EventHandlerNonNull*@http://web-platform.test:8000/focus/focus-restoration-in-different-site-iframes.html:8:1
[task 2020-06-05T13:37:55.413Z] 13:37:55 INFO - TEST-OK | /focus/focus-restoration-in-different-site-iframes.html | took 4294ms

Please investigate this frequent failure - test got added in bug 1634363.

Flags: needinfo?(hsivonen)
Regressed by: 1634363

I'm a bit surprised that this happens in an opt build. Are there environmental factors that can make CI run slowly even in the case of opt builds. The obvious option would be to increase the timer values and see if that's better. (WPT doesn't have the facilities for waiting for the right things, so the test is timer-based.)

Assignee: nobody → hsivonen
Status: NEW → ASSIGNED

Let's try the attached patch and see if it helps at all.

Flags: needinfo?(hsivonen)
Pushed by hsivonen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/aa66effc4d07
Increase wait times for focus-restoration-in-different-site-iframes.html. r=jgraham
Failed to create upstream wpt PR due to merge conflicts. This requires fixup from a wpt sync admin.
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla79
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/24782 for changes under testing/web-platform/tests
You need to log in before you can comment on or make changes to this bug.