Closed Bug 1643780 Opened 4 months ago Closed 3 months ago

Implement theme screen in multistage about:welcome

Categories

(Firefox :: Messaging System, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 79
Iteration:
79.2 - June 15 - June 28
Tracking Status
firefox78 --- unaffected
firefox79 --- verified

People

(Reporter: pdahiya, Assigned: pdahiya)

References

(Blocks 1 open bug)

Details

Attachments

(4 files)

Scope of this bug is to implement theme screen to support multistage about:welcome v2 round of experiments in 79

https://docs.google.com/document/d/1gm8vWNoBBXdRRfFaGZpkMVyJk0mTzidPUeljMEFQxc4/edit#heading=h.kwga5rwu7l69

Assignee: nobody → pdahiya
Iteration: --- → 79.1 - June 1 - June 14
Priority: -- → P1
Iteration: 79.1 - June 1 - June 14 → 79.2 - June 15 - June 28

Created bug 1645824 to implement theme preview. Scope of this bug is to implement theme screen with light and dark theme as option, click of 'Save Theme' should keep selected theme and progress to next step. Clicking Secondary CTA link will revert to the default theme, and progress to the next step

Duplicate of this bug: 1645824
Attached image Screenshot Theme Screen

NI Aaron for UI review of theme screens attached. Thanks!

Flags: needinfo?(abenson)
Pushed by pdahiya@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/aa0a5591f010
Implement theme screen in multistage about:welcome r=Mardak
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/90b514d14455
Implement theme screen in multistage about:welcome r=Mardak

Looks like the failures were actually caused by Bug 1647470. Relanded. Please ignore comment 9.

Flags: needinfo?(pdahiya)
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 79

(In reply to Punam Dahiya [:pdahiya] from comment #7)

NI Aaron for UI review of theme screens attached. Thanks!

Sorry for the delay, have been out sick.

The two theme cards aren't centered. I would guess there's a right margin applied to the second (last) card which is pushing it off-center. We might consider a :last-child selector here so that no matter how many themes we have, there's no extra margin applied.

Other than that, looks good!

Flags: needinfo?(abenson)

Oh, it also looks like the cards don't have the correct border-radius. The unselected card has a border radius on the bottom left/right corner but not the top, and the selected card has no border radius. See the spec for an example.

Hey @Punam,

Will the fixes for the issues mentioned by @Aaron in comment 13, and comment 14 be handled in this bug or there will be another one logged?

Flags: needinfo?(pdahiya)

(In reply to Robert Martin [:romartin], Ecosystem QA from comment #15)

Hey @Punam,

Will the fixes for the issues mentioned by @Aaron in comment 13, and comment 14 be handled in this bug or there will be another one logged?

Hi Robert!
Aaaron UI review feedback fixes were rolled in with UI fixes in bug 1648538 and should be fixed in today's Nightly. Thanks!

Flags: needinfo?(pdahiya)

I have verified that there is a "theme screen" correctly displayed in the "about:welcome" page using Firefox Nightly 80.0a1 (Build ID: 20200629154604) and Firefox Beta 79.0b1 (2020069224419) on Windows 10 x64, macOS 10.15, and Ubuntu Linux 18.04.

Given the above and comment 16, I'm marking this enhancement as VERIFIED.

Status: RESOLVED → VERIFIED
Blocks: 1653859
You need to log in before you can comment on or make changes to this bug.