Closed Bug 1643896 Opened 11 months ago Closed 11 months ago

The pop-up bubble for ImTranslator extension for Firefox stopped working

Categories

(WebExtensions :: Untriaged, defect)

defect

Tracking

(firefox-esr68 unaffected, firefox77 unaffected, firefox78 unaffected, firefox79 verified)

VERIFIED FIXED
mozilla79
Tracking Status
firefox-esr68 --- unaffected
firefox77 --- unaffected
firefox78 --- unaffected
firefox79 --- verified

People

(Reporter: bj, Assigned: zombie)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

The ImTranslator add-on creates a pop-up bubble when text is selected. This text appears in Firefox 76.0.1 but not in Nightly.

mozregression shows the problem started with this:

https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=e8d0f18c2300a223c31847d27196d1a8ad673515&tochange=ca3057f6cdc555f3ddfb1f10afa6805a43253a85

The add-on:
https://addons.mozilla.org/en-US/firefox/addon/imtranslator/

Has Regression Range: --- → yes
Regressed by: 1583484
Assignee: nobody → tomica

When there are multiple runtime.onMessage listeners in the same context, if
the first one sends a response, but the second one throws, the exception wins
the race because we convert all responses into async promises.

Converting the sync exception into an async promise rejection ensures we process
them in the original order.

This extension is bonkers, the code is awful and it's only by accident that it even worked at all. One of the 4 onMessage listeners in the background page throws whenever it receives a message that every content script sends when it is loaded.

Sad thing is, I'm sure there are other extensions which are similarly broken, so we may as well fix this.

Pushed by tjovanovic@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/acd373902b37
Convert sync onMessage listener exceptions into async rejections r=mixedpuppy
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla79
Flags: qe-verify+

Hello,

Verified the fix using the latest Nightly (79.0a1/20200617215206) under Windows 10 Pro 64-bit and Ubuntu 16.04 LTS. Also reproduced the issue on an older Nightly (79.0a1/20200601214228) for comparison purposes.

When text is selected the pop-up bubble is properly displayed, confirming the fix.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.