Closed Bug 1644285 Opened 11 months ago Closed 11 months ago

Wrong Arimo fonts selected on anandtech.com

Categories

(Core :: Layout: Text and Fonts, defect)

Unspecified
Linux
defect

Tracking

()

VERIFIED FIXED
mozilla79
Tracking Status
firefox79 --- verified

People

(Reporter: johnp, Assigned: jfkthame)

References

()

Details

Attachments

(1 file)

With gfx.e10s.font-list.shared;true on latest Nightly and google-croscore-arimo-fonts installed on Fedora 32 the Arimo font on anandtech.com selects the bold italic variant in the main text (font-weight: 400) and the regular one in the "Pipeline Stories" header (font-weight: 700). Fonts are chosen correctly with the shared font list disabled. This also happens with a clean profile (only gfx.e10s.font-list.shared;true) as early as Firefox version 68.

That's....weird. I can reproduce also on Ubuntu with the fonts-croscore package installed. Will look into it; thanks for reporting.

Assignee: nobody → jfkthame
Severity: -- → S2

OK, I think I see what the problem is here. When collecting the font names for src:local() lookups we record the family and face index within the family of each available font; but then when storing the faces into the font list, we potentially re-sort the faces (if it is a "simple" family with no more than the standard 4 styles), and that invalidates the face indexes that we stored in the src:local table.

Pushed by jkew@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8dd6a0eada60
Use descriptor rather than index (which might change) to record font face in local-names InitData record on Linux. r=jwatt
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla79
Regressions: 1645587
Flags: qe-verify+

Reproduced in Nightly 79.0a1 (2020-06-08) (20200608094842) on Ubuntu 18.04.4.
Verified > Fixed on the latest Nightly 80.0a1 (2020-07-01) (20200701093012) and beta 79.0b2 (20200630191632) on Ubuntu 18.04.4.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.