Closed Bug 1644337 Opened 8 months ago Closed 5 months ago

Date Picker UI by <input type=date> in unexpected position with Fission

Categories

(Firefox :: General, defect)

Unspecified
All
defect

Tracking

()

RESOLVED FIXED
81 Branch
Fission Milestone M6b
Tracking Status
firefox81 --- fixed

People

(Reporter: m_kato, Assigned: enndeakin)

References

Details

(Whiteboard: [layout:triage-discuss])

Attachments

(3 files)

Attached image screenshot with fission

Environment

macOS 10.15.4
Firefox Nightly 79 2020-06-08

Step

  1. fission.autostart=true, then restart
  2. Browse https://developer.mozilla.org/en-US/docs/Web/HTML/Element/input
  3. Set focus to <input type=date>'s control
  4. Click yyyy

Result

Date picker UI is top-left in content window

Expected Result

Date picker UI should be bottom of <input type=date>. Of course, if without fission, this doesn't occur.

Sending this Fission Date Picker bug to Layout triage. This bug blocks enabling Fission in Nightly.

I can also reproduce this bug on Windows 10.

Severity: -- → S3
Fission Milestone: --- → M6b
OS: macOS → All
Priority: -- → P3
Whiteboard: [layout:triage-discuss]

The color picker UI has the same positioning bug as the date picker.

Here is a color picker test case: https://developer.mozilla.org/en-US/docs/Web/HTML/Element/input/color

Summary: Date picker UI by <input type=date> is unexpected position with fission → Date Picker UI by <input type=date> and Color Picker UI by <input type="color"> in unexpected position with Fission

On my linux box, the color picker window is positioned at the center of the browser window.

Chris, can you please open a new bug for the color picker issue you are seeing? Maybe it's a different issue I am going to move the date picker issue into Toolkit.

So, I think a problem here in DateTimePickerChild.jsm, BrowserUtils.getElementBoundingRect probably doesn't work in fission world. Probably GeometryUtils.getBoxQuadsFromWindowOrigin can be used (But we might wand to add a new ChromeOnly API for the date picker or some such).

Component: Layout: Form Controls → Form Manager
Flags: needinfo?(cpeterson)
Product: Core → Toolkit
Summary: Date Picker UI by <input type=date> and Color Picker UI by <input type="color"> in unexpected position with Fission → Date Picker UI by <input type=date> in unexpected position with Fission

The product::component has been changed since the backlog priority was decided, so we're resetting it.
For more information, please visit auto_nag documentation.

Priority: P3 → --
See Also: → 1647583

(In reply to Hiroyuki Ikezoe (:hiro) from comment #4)

Chris, can you please open a new bug for the color picker issue you are seeing? Maybe it's a different issue I am going to move the date picker issue into Toolkit.

I filed new bug 1647583 for the color picker issue. Turns out it's an existing bug and not a Fission bug. :)

Flags: needinfo?(cpeterson)

The Date/Time picker is outside the scope of Form Manager. I probably would have left this in "Layout: Form Controls" but I guess it is the front-end team that has been touching this most recently.

Component: Form Manager → General
Product: Toolkit → Firefox
See Also: → 1413099

Mike, is this something you could look into or know who should?

Flags: needinfo?(mconley)

I suspect this will have the same underlying cause as the misplaced <select> dropdown, which we solved. Perhaps Neil has time to look at this?

Flags: needinfo?(mconley) → needinfo?(enndeakin)
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Flags: needinfo?(enndeakin)
Pushed by neil@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9fb094f206b3
add an isAnchored property to popups, as popups can be anchored to a rectangle as well as a node. This prevented the arrow from appearing in panels, r=smaug
https://hg.mozilla.org/integration/autoland/rev/3bdd93319474
anchor the date time picker dropdown panel to a screen rectangle, as a node will not be available for out of process iframes, r=ntim
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch
You need to log in before you can comment on or make changes to this bug.