Closed Bug 1644346 Opened 4 months ago Closed 4 months ago

Firefox does not support Unicode Emoji v12.1 or higher (Emoji 13.0)

Categories

(Core :: Graphics: Text, enhancement)

77 Branch
enhancement

Tracking

()

VERIFIED FIXED
mozilla79
Tracking Status
firefox78 --- verified
firefox79 --- verified

People

(Reporter: c4609174, Assigned: jfkthame)

References

Details

Attachments

(3 files)

Attached file emoji-test.html

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:77.0) Gecko/20100101 Firefox/77.0

Steps to reproduce:

Open the attached emoji-test.html on Linux. (Fedora 32 here)

Actual results:

emoji 12.1 combined with ZWJ are shown as two emojis

Expected results:

display all emojis https://emojipedia.org/emoji-12.1/

Attached image broken-emojis.png

Here is how it looks with Firefox 77.

And BugZilla breaks the HTML file when viewing…

Here is a gist: https://gist.github.com/rugk/10131a881d73999bbd2493e935285dc9 (can also be seen in source code view)

And BugZilla breaks the HTML file when viewing…

Here is a gist: https://gist.github.com/rugk/10131a881d73999bbd2493e935285dc9 (can also be seen in source code view)

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Graphics: Text
Product: Firefox → Core

(In reply to rugk from comment #2)

And BugZilla breaks the HTML file when viewing…

The problem there is that the file doesn't have a <meta charset=utf-8> tag, and gets loaded as Latin-1; explicitly choosing Unicode from the View / Text Encoding menu should fix that.

The emoji-12.1 combinations work fine here on macOS 10.15 (in both Firefox 77 and Nightly). I think this is just a question of having adequate font support. So this is dependent on https://github.com/mozilla/twemoji-colr/pull/53, and then once we've merged that, we need to update the bundled twemoji font.

Severity: -- → S3
Assignee: nobody → jfkthame
Pushed by jkew@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/87ad6cc2ae3f
Update bundled Twemoji Mozilla font to v0.5.1 to support new emojis. r=lsalzman
Status: UNCONFIRMED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla79

Wow, thanks! That was a fix in record time.

The problem there is that the file doesn't have a <meta charset=utf-8> tag, and gets loaded as Latin-1; explicitly choosing Unicode from the View / Text Encoding menu should fix that.

As for that Bugzilla issue, I've reported it in Bug 1644352.

I mean if you open the file locally, Firefox also detects it as Unicode. IMHO if you upload it here, the behaviour should not be different in the end.

Given that you upload files on Bugzilla, because you want to provide STR, IMHO Bugzilla should do everything so it all works just as if you open them locally (or so). Otherwise it just breaks the STR.

Can this please be uplifted to Firefox 78 Beta, so that is makes it into 78 ESR and Thunderbird 78, so those users do not have to wait another year.

(In reply to tdulcet from comment #10)

Can this please be uplifted to Firefox 78 Beta, so that is makes it into 78 ESR and Thunderbird 78, so those users do not have to wait another year.

Yes, given that 78 is due to be an ESR release, I think this makes sense; let's put in a request to the release managers.

Comment on attachment 9155230 [details]
Bug 1644346 - Update bundled Twemoji Mozilla font to v0.5.1 to support new emojis. r=lsalzman

Beta/Release Uplift Approval Request

  • User impact if declined: Recently-added emoji characters/combinations don't display correctly
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: With Nightly on Linux, load the reporter's test at https://gist.github.com/rugk/10131a881d73999bbd2493e935285dc9 and check the emoji render correctly (as single images, not sequences)
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): No code change, just updating the version of the bundled emoji font.
  • String changes made/needed:
Attachment #9155230 - Flags: approval-mozilla-beta?
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Comment on attachment 9155230 [details]
Bug 1644346 - Update bundled Twemoji Mozilla font to v0.5.1 to support new emojis. r=lsalzman

sounds ok, approved for 78.0b6

Attachment #9155230 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Reproduced the initial issue with Release 77.0.1 (build id: 20200602222727).
Verified - Fixed in latest Nightly build 79.0a1 (build id: 20200610214041) using Ubuntu 18.04.

Verified - Fixed in Beta build 78.0b6 (build id: 20200611104559) using Ubuntu 18.04.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.