Closed Bug 1644606 Opened 2 years ago Closed 1 month ago

Add a pref to select between GLES and desktop GL contexts on EGL

Categories

(Core :: Graphics, enhancement, P3)

77 Branch
Unspecified
Linux
enhancement

Tracking

()

RESOLVED FIXED
95 Branch
Tracking Status
firefox95 --- fixed

People

(Reporter: eric, Assigned: rmader)

References

(Blocks 3 open bugs)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:77.0) Gecko/20100101 Firefox/77.0

Steps to reproduce:

A Mesa developer trying to debug a webgl rendering error for an ARM graphics driver (freedreno) tried bringing up the page on desktop Linux so that we could produce an apitrace for it and get down to debugging. However, we found that we were getting a desktop GL context, and not reproducing the failure (since desktop GL doesn't respect mediump, where the driver bug was).

For debugging issues on Mesa drivers, it would be nice to be able to switch a normal desktop firefox build between the APIs that firefox supports.

The workaround for forcing GLES for this particular webgl2 app was "MOZ_ENABLE_WAYLAND=1 MESA_GL_VERSION_OVERRIDE=2.1 ./firefox", thanks to Robert Mader

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Canvas: WebGL
Product: Firefox → Core
Severity: -- → S3
Status: UNCONFIRMED → NEW
Component: Canvas: WebGL → Graphics
Ever confirmed: true
Priority: -- → P3
Blocks: wr-linux
OS: Unspecified → Linux
See Also: → linux-egl
See Also: linux-egl
Summary: add a pref to select between GLES and desktop GL contexts on linux → Add a pref to select between GLES and desktop GL contexts on EGL

This preference was requested by driver developers, simplifying
debugging processes. It is especially useful on Linux, but way
be handy on other platforms as well.

As a side effect it also ensures the two places with fallback paths
behave the same again on Android.

Depends on D128411

Assignee: nobody → robert.mader
Status: NEW → ASSIGNED
Depends on: 1702546
Pushed by robert.mader@posteo.de:
https://hg.mozilla.org/integration/autoland/rev/07e60ed33cc0
Add a pref to select between GLES and desktop GL contexts on EGL, r=gfx-reviewers,nical
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch
You need to log in before you can comment on or make changes to this bug.